Closed Bug 1452409 Opened 3 years ago Closed 3 years ago

Crash in free.cold.85 | mozilla::wr::Moz2DRenderCallback

Categories

(Core :: Graphics: WebRender, defect)

Unspecified
Linux
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- disabled

People

(Reporter: calixte, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

This bug was filed from the Socorro interface and is
report bp-16247281-01c1-443c-8832-663070180407.
=============================================================

Top 10 frames of crashing thread:

0 firefox free.cold.85 
1 libxul.so mozilla::wr::Moz2DRenderCallback gfx/webrender_bindings/Moz2DImageRenderer.cpp:280
2 libxul.so wr_moz2d_render_cb gfx/webrender_bindings/Moz2DImageRenderer.cpp:312
3 libxul.so rayon_core::job::{{impl}}::execute<closure> src/libcore/option.rs:262
4 libxul.so libxul.so@0x3d01078 
5 libxul.so libxul.so@0x3d00dee 
6 libxul.so libxul.so@0x3d00a1b 
7 libxul.so libxul.so@0x3d28993 
8 libpthread-2.27.so libpthread-2.27.so@0x75a9 
9 libc-2.27.so libc-2.27.so@0xf6cbe 

=============================================================

There are 2 crashes (from 1 installation) in nightly 61 with buildid 20180407100152. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1451761.

[1] https://hg.mozilla.org/mozilla-central/rev?node=e388d63a08d9
Flags: needinfo?(jmuizelaar)
Duplicate of this bug: 1452387
Flags: needinfo?(jmuizelaar)
A user commented on his crash:
>  After start benchmark on web.basemark.com , firefox-nightly crashed 

I could reproduce this with a fresh profile and gfx.webrender.all + gfx.webrender.blob.invalidation.
Just open https://web.basemark.com, click on Start and wait about a minute. Got a browser crash at "SVG Test (10/20)".
bp-3457627c-3b73-47d1-a051-7362a0180411 

Two runs with blob-inval: Browser crash at "SVG Test (10/20)".
Two runs without blob-inval: No Crash.
I think this will be fixed by bug 1453090
See Also: → 1453718
I can't reproduce this crash signature anymore (WFM). From my point of view this has morphed into bug 1453718.
For the time being I'm incompetent to detect a change of "MOZ_CRASH Reason" with mozregression. I can just say that it permanantly crashed.
Status: NEW → RESOLVED
Closed: 3 years ago
Depends on: 1453090
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.