Closed Bug 1453718 Opened 3 years ago Closed 3 years ago

blob-invalidation: Crash in [...] | webrender::renderer::Renderer::update_texture_cache

Categories

(Core :: Graphics: WebRender, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 --- disabled

People

(Reporter: jan, Assigned: jrmuizel)

References

(Blocks 1 open bug, )

Details

(Keywords: crash, nightly-community)

Crash Data

Nightly 61 x64 20180412100111 de_DE 246c614e160586c1eb3167cff866dd550be35e03 @ Debian Testing, KDE, Radeon RX480
fresh profile: gfx.webrender.all, gfx.webrender.blob.invalidation

Suspicion: Bug 1453090 might have morphed the crash from bug 1452409 into this one. I don't know how to enable the regular crash reporter inside mozregression and -B debug doesn't enlighten me either.

STR from bug 1452409 comment 2:
> gfx.webrender.all + gfx.webrender.blob.invalidation.
> Just open https://web.basemark.com, click on Start and wait about a minute. Got a browser crash at "SVG Test (10/20)".

bp-b5b0b744-6a83-462d-988e-dacc70180412 12.04.18 17:49 (browser crash)
> slice index starts at 88297052 but ends at 1048576

bp-b49449f3-8a7f-496d-bf89-c828b0180412 12.04.18 18:40
> slice index starts at 88297052 but ends at 1048576

I couldn't reproduce without blob-invalidation.
Looking at this now...
I can reproduce it in rr
Actually, I mistook, that's the PopClip crash that I reproduce. Let's see...
I have it now.
This actually might be fixed by bug 1452401
Looks like it isn't.
It looks like the problem is an interaction with large tiled blob images and dirty rects
Assignee: nobody → jmuizelaar
Depends on: 1453688
Status: NEW → RESOLVED
Has STR: --- → yes
Closed: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.