[KDE] Selectors that have .solid-csd class do not work

RESOLVED INVALID

Status

()

defect
RESOLVED INVALID
a year ago
8 months ago

People

(Reporter: vladzzag, Assigned: stransky)

Tracking

(Blocks 1 bug)

61 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180408100251

Steps to reproduce:

* Install latest KDE Plasma (at this moment, 5.12.4)
* Use Breeze GTK theme(Go to System Settings > Application Style > GNOME Application Style (GTK) and pick Breeze under "Select a GTK3 theme")
* Disable title bar in Firefox
* Unmaximize Firefox (if it was maximized)


Actual results:

Corners are round. See the attached picture.


Expected results:

Corners should have been sharp because Breeze GTK has the following rule:

```
  .solid-csd decoration {
    border-radius: 0;
    margin: 0;
    padding: 0px;
    border: none;
    background-color: #556068;
    box-shadow: none; }
```

source: https://github.com/KDE/breeze-gtk/blob/master/Breeze-gtk/gtk-3.20/gtk.css#L3630

Also, I've tried using the following rule but without success

```
.solid-csd headerbar.default-decoration,
.solid-csd .titlebar.default-decoration {
  border-radius: 0; }
```

Without `.solid-csd` class it works, corners of Firefox are sharp.

Most likely, Firefox somehow mishandles rules which have .solid-csd class in their selectors.
(Reporter)

Updated

a year ago
Blocks: gtktitlebar
(Assignee)

Comment 1

a year ago
That's because "solid-csd" is a class used for decorations for uncomposited environment, without alpha blending and semi-transparent shadows. We use "csd" class as we support transparent window borders.
(Reporter)

Comment 2

a year ago
So, indeed, it seems like that's theme related issue (related to css precedence, I guess).
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Assignee)

Updated

a year ago
See Also: → 1456898
(Assignee)

Comment 3

a year ago
I'll investigate this as we need to support KDE somehow.
Assignee: nobody → stransky
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---
(Assignee)

Updated

a year ago
Status: REOPENED → ASSIGNED
Summary: Selectors that have .solid-csd class do not work → [KDE] Selectors that have .solid-csd class do not work
(Assignee)

Comment 4

8 months ago
KDE is supported well now so closing this as a theme bug.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago8 months ago
Resolution: --- → INVALID
(In reply to Martin Stránský [:stransky] from comment #4)
> KDE is supported well now so closing this as a theme bug.

No, I still can't resize the window.
(Assignee)

Comment 6

8 months ago
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #5)
> (In reply to Martin Stránský [:stransky] from comment #4)
> > KDE is supported well now so closing this as a theme bug.
> 
> No, I still can't resize the window.

Can you please file a new bug and attach some screenshot there? This one is about Breeze GTK theme on KDE.
(Reporter)

Comment 7

8 months ago
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #5)
> No, I still can't resize the window.

That's because of Breeze GTK theme. See

https://github.com/KDE/breeze-gtk/blob/master/Breeze-gtk/gtk-3.20/gtk.css#L3691
If Firefox relies on a buggy dependency to realize a feature, the bug should either be reported and fixed upstream or circumvented in Firefox. Should we reopen this bug until it's fixed or mark it as wontfix instead? It's all, but not invalid.^^
(Reporter)

Comment 9

8 months ago
Also, I can confirm that now corners are sharp. :)
(In reply to Martin Stránský [:stransky] from comment #6)
> Can you please file a new bug and attach some screenshot there?

bug 1453386 was about this.
(Assignee)

Comment 11

8 months ago
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #10)
> (In reply to Martin Stránský [:stransky] from comment #6)
> > Can you please file a new bug and attach some screenshot there?
> 
> bug 1453386 was about this.

I reopened bug 1453386 as it's about the resize.
You need to log in before you can comment on or make changes to this bug.