[KDE] Poor Firefox titlebar style when CSD is enabled

NEW
Unassigned

Status

()

defect
P5
normal
Last year
19 days ago

People

(Reporter: vladzzag, Unassigned)

Tracking

(Blocks 1 bug, {nightly-community})

61 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

Last year
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180411100123

Steps to reproduce:

* use latest KDE Plasma(at this moment, 5.12.4)
* enable CSD
* try to resize Firefox with mouse


Actual results:

Can't resize the browser. Also, there is no any feedback which tells users that it's possible to resize window.


Expected results:

Users should be able to resize Firefox with mouse and have proper feedback(e.g. cursor changes its icon to arrows near edges of the window frame).
Reporter

Updated

Last year
Blocks: gtktitlebar
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

Last year
Checked 61.0a1 (2018-04-19) on KDE (Xorg). Cursor is changing to proper one, resizing also works.
The only small issue I've noticed is that resizing it from the right side looks more choppy then from left.
Would be glad to help with the issue.
Reporter

Comment 2

Last year
(In reply to Vavooon from comment #1)
> Checked 61.0a1 (2018-04-19) on KDE (Xorg). Cursor is changing to proper one,
> resizing also works.
> The only small issue I've noticed is that resizing it from the right side
> looks more choppy then from left.
> Would be glad to help with the issue.

That's really strange..

Could you please give more information about your system? E.g.

- Distro
- KDE Plasma version
- Qt version
- GTK version
- GTK theme name

---

Mine for reference:

- Distro: Arch Linux
- KDE Plasma version: 5.12.4
- Qt version: 5.10.1
- GTK version: 3.22.30
- GTK [3] theme name: Breeze
Flags: needinfo?(vavooon)

Comment 3

Last year
Sure:

- Kubuntu 17.10
- KDE 5.12.4
- Qt 5.9.1
- GTK 3.22.25
- Ark theme

I've tried it on latest firefox-trunk (version 61.0a1 from 2018-04-19) from Ubuntu repo.

BTW do you know where is bug ticket for disappearing window control buttons after hover in CSD? I couldn't find it, however I remember that it was created by someone earlier.
Flags: needinfo?(vavooon)
Debian Testing
KDE Plasma 5.12.4
KDE Framework 5.44.0
Qt 5.10.1

It's possible for me to resize the window when using the Gtk3 Default Theme. I don't like the large white border, so I selected Breeze whose window button look matches KDE's, but the window isn't resizable then.
Reporter

Comment 5

Last year
So, it seems like that's an issue related to Breeze GTK3 theme. When using Adwaita theme, I can resize Firefox with mouse. Given that, what rules should someone use to add resize extents in a GTK theme?
Reporter

Comment 6

Last year
That's totally theme issue (mostly because of gtk and argb support, I guess).
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → INVALID
The same KDE-style theme (Breeze) works perfectly on Gnome. Firefox can't just get broken if the user selects another theme that is also shipped with Debian.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Reporter

Comment 8

Last year
(In reply to Jan Andre Ikenmeyer [:darkspirit] from comment #7)
> The same KDE-style theme (Breeze) works perfectly on Gnome. Firefox can't
> just get broken if the user selects another theme that is also shipped with
> Debian.

According to https://github.com/KDE/breeze-gtk/blob/master/Breeze-gtk/gtk-3.20/gtk.css#L3609 

decoration {
  border-radius: 3px 3px 0 0;
  border-width: 0px;
  box-shadow: 0 2px 6px 1px rgba(0, 0, 0, 0.5);
  /* this is used for the resize cursor area */
  margin: 10px; }

  .solid-csd decoration {
    border-radius: 0;
    margin: 0;
    padding: 0px;
    border: none;
    background-color: #556068;
    box-shadow: none; }

it works as expected.
Reporter

Updated

Last year
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → INVALID
Sorry, I don't want to file a duplicate of this bug, so please don't close this any more. comment 0 is not fixed. One can resize a Nightly window with Breeze Gtk (the KDE skin) on Gnome, but not on KDE.
Regardless what the theme might say, Nightly's window resize feature should work with most common themes. Even if Nightly might has to do a small trick or if this bug has to be reported somewhere upstream. Nightly is suffering from it.
Thunderbird is also affected.
Okay, let's see if we can find any workaround here for Firefox.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Duplicate of this bug: 1469822
I wonder if we can use MozWindowFrame* elements for that.
Status: REOPENED → NEW

Comment 14

9 months ago
Ok The resize not working from the window element if you dont want see plasma own borders on top of firefox.
You need do it from window menu (alt+f3 by default). So the the main problem is in kde.

Comment 15

9 months ago
I just upgraded to Debian testing which now ships Plasma 5.13.5, but strangely this issue only affects the firefox-esr (60.2.2esr) I installed from stable security update, Thunderbird and the Tor Browser are not affected.

Comment 16

8 months ago
For me, on Fedora 29 with Plasma 5.13.5, the issue affects regular Firefox (62.0.3) as well. This is on a F29 KDE installation with the default Plasma theme (Breeze).
Looks like Firefox does not pick up correct CSD style on KDE. When I try gedit for instance it looks as well as under gnome-shell, has shadows/theme and so but firefox has solid-csd decorations and default Adwaita theme. I wonder what causes that...
Summary: [KDE] Cannot resize Firefox with mouse when CSD is enabled → [KDE] Poor Firefox titlebar style when CSD is enabled
(In reply to Martin Stránský [:stransky] from comment #17)
> Looks like Firefox does not pick up correct CSD style on KDE. When I try
> gedit for instance it looks as well as under gnome-shell, has shadows/theme
> and so but firefox has solid-csd decorations and default Adwaita theme. I
> wonder what causes that...

Hm, that seems to be functional only under plasma-wayland session. X11 plasma gives to all gtk+ applications solid-csd style and I don't know why.

Comment 19

4 months ago

somehow related:
https://bugs.kde.org/show_bug.cgi?id=390550
https://gitlab.gnome.org/GNOME/gtk/issues/100

this have been more than 1 year, and we can't even be sure whose bug is it...

(In reply to 61.1p57 from comment #19)

somehow related:
https://bugs.kde.org/show_bug.cgi?id=390550
https://gitlab.gnome.org/GNOME/gtk/issues/100

this have been more than 1 year, and we can't even be sure whose bug is it...

When Firefox looks differently than other Gtk CSD applications (gedit for instance) then it's Firefox fault. When all Gtk CSD apps look wrongly then it's perhaps KDE fault.

Comment 21

3 months ago

At least comment 2 at the KDE bug seems like it provides some insight to comment 18 here.

You need to log in before you can comment on or make changes to this bug.