Closed Bug 1452906 Opened 4 years ago Closed 4 years ago

Cursor misplaced in contenteditable after pressing Backspace

Categories

(Core :: DOM: Editor, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1453872
Tracking Status
firefox-esr52 --- unaffected
firefox59 --- affected
firefox60 --- affected
firefox61 --- affected

People

(Reporter: comandeer, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_4) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.181 Safari/537.36

Steps to reproduce:

Original bug report: https://github.com/ckeditor/ckeditor-dev/issues/1878

However it could be reproduced on native `[contenteditable]`, e.g. on https://developer.mozilla.org/en-US/docs/Web/Guide/HTML/Editable_content

1. Place cursor at the end of the first paragraph.
2. Press Shift + Enter.
3. Type some text.
4. Place cursor at the beginning of the second line of text.
5. Press Backspace.


Actual results:

The two lines of text are joined, however the cursor is misplaced. It's not placed exactly where the join occurred (after the dot from the first line) but several characters before/after).


Expected results:

Cursor after the join should be placed exactly where the join occurred.
Version 	61.0a1
User Agent 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0

I was able to reproduce this issue on the latest Firefox release and the latest Nightly on Windows 10 x64, Mac 10.13.3 and Arch Linux. 

 8:47.53 INFO: Last good revision: ec4df7b61cce17758ac02acc834a4e8c7dbc0767
 8:47.54 INFO: First bad revision: 92403ed2a4880fc6dde143ccf4cf3b5d725e4bff
 8:47.54 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=ec4df7b61cce17758ac02acc834a4e8c7dbc0767&tochange=92403ed2a4880fc6dde143ccf4cf3b5d725e4bff

It looks like bug 1423835 has caused this.

@masayuki, could you please take a look at this?
Blocks: 1423835
Status: UNCONFIRMED → NEW
Component: Untriaged → Editor
Ever confirmed: true
Flags: needinfo?(masayuki)
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
Wow, timely report. I found this bug when I clean up editor code a couple of days ago. We already have a patch, but this report is really useful to create testcase! Thank you!
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(masayuki)
Resolution: --- → DUPLICATE
Duplicate of bug: 1453872
You need to log in before you can comment on or make changes to this bug.