Closed Bug 1453049 Opened 4 years ago Closed 2 years ago

Crash in libhwui.so@0x8705e

Categories

(Firefox for Android Graveyard :: General, defect, P3)

Firefox 59
Unspecified
Android
defect

Tracking

(firefox59 wontfix, firefox60 wontfix, firefox61 wontfix, firefox62 wontfix, firefox63 wontfix, firefox64 fix-optional, firefox65 fix-optional)

RESOLVED WORKSFORME
Tracking Status
firefox59 --- wontfix
firefox60 --- wontfix
firefox61 --- wontfix
firefox62 --- wontfix
firefox63 --- wontfix
firefox64 --- fix-optional
firefox65 --- fix-optional

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [priority:medium])

Crash Data

This bug was filed from the Socorro interface and is
report bp-038a2a16-fb7f-40cf-8cf8-e97ab0180410.
=============================================================

Samsung API 26 specific crash seen on release: https://bit.ly/2GM27Wx

Comments:
*firefox has been crashing 2-3 times a day for the past couple of weeks. I have Samsung Galaxy S8 Plus 

Top 10 frames of crashing thread:

0 libc.so libc.so@0x4bba8 
1 libhwui.so libhwui.so@0x8705e 
2 libhwui.so libhwui.so@0x8705e 
3 libhwui.so libhwui.so@0x91386 
4 liblog.so liblog.so@0x66db 
5 libhwui.so libhwui.so@0x87ee3 
6 liblog.so liblog.so@0x66f6 
7 boot-org.apache.http.legacy.boot.oat boot-org.apache.http.legacy.boot.oat@0x21270 
8 dalvik-main space (region space)_945_945 (deleted) dalvik-main space @0x1cb36267 
9 boot-core-oj.oat boot-core-oj.oat@0x774463 

=============================================================
See Also: → 1451100
[triage] Release top crasher #28: that being said, I'm not sure how many crashes is actually significant on our release population.
tracking-fennec: --- → ?
Flags: needinfo?(sdaswani)
Priority: -- → P1
Liz thoughts on priority?
Flags: needinfo?(sdaswani) → needinfo?(lhenry)
Well, if it might be related to the S8/Oreo top crasher that we're seeing on fennec, it would be useful to investigate, but I don't know how to tell if it's related or not.
Flags: needinfo?(lhenry)
P1 here without an assignee, lets downgrade or find an owner.
Flags: needinfo?(sdaswani)
Priority: P1 → P2
The two devices affected in this crash are dream2qltesq and dreamqltesq, which are also implicated in Bug 1450793. Comments mention repeatedly crashing.
Removing NI as it's a P2 now.
Flags: needinfo?(sdaswani)
Some recent comments:

*Firefox on Android Oreo 8.0 crashes a lot. Fix it. 
*Crashes several times per day. galaxy s8 oreo 
*Firefox has crashed or force closed at least once daily since I upgraded phone to Android Op System Oreo
Adding another signature to this bug. Just like the initial signature, these are all crashes using API 26 and Samsung devices. Over 80% of the crashes are using Samsung SM-N950U.
Crash Signature: [@ libhwui.so@0x8705e] → [@ libhwui.so@0x8705e] [@ libhwui.so@0x870c6]
Crash Signature: [@ libhwui.so@0x8705e] [@ libhwui.so@0x870c6] → [@ libhwui.so@0x8705e] [@ libhwui.so@0x870c6] [@ libhwui.so@0x87096]
I added a signature here that is affecting S9 devices, all running API 26.
tracking-fennec: ? → ---
Re-triaging per https://bugzilla.mozilla.org/show_bug.cgi?id=1473195

Needinfo :susheel if you think this bug should be re-triaged.
Priority: P2 → P5
moving back to P2
Priority: P5 → P2
Susheel, do you intend to find an owner for this bug before 63 ships? It's not high volume but with ~200 crashes per day across channels, it's not insignificant either. Let me know so as that I can make a decision on keeping the tracking flag or not  for 63. Thanks!
Flags: needinfo?(sdaswani)
I've put it on our medium priority queue. So perhaps it doesn't need to track 63 given it's not hugely impactful?
Flags: needinfo?(sdaswani)
Whiteboard: [priority:medium]
(In reply to :sdaswani only needinfo from comment #13)
> I've put it on our medium priority queue. So perhaps it doesn't need to
> track 63 given it's not hugely impactful?

I am going to keep on tracking it but mark it as fix-optional for 63, we are still early in the beta cycle and I'll be happy to uplift a low risk patch for this crash if we have one.
In one crashreport [1] I saw
> GraphicsCriticalError :  BlitImage(SurfaceTextureImage) not implemented.

And then found that [2]
> We removed or disabled the SurfaceTexture blitting

They may be related?

[1] https://crash-stats.mozilla.com/report/index/5ca76879-9c92-4877-b3b2-2f3560181003#tab-metadata
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=1401090#c3
Flags: needinfo?(snorp)
> In one crashreport [1] I saw
> > GraphicsCriticalError :  BlitImage(SurfaceTextureImage) not implemented.
> 
> And then found that [2]
> > We removed or disabled the SurfaceTexture blitting
> 
> They may be related?

It's probably not related. This crash is in Android's drawing code for the UI, which Gecko doesn't use.
Flags: needinfo?(snorp)
QA Contact: sdaswani
Pascal does this still need to track 63?
Flags: needinfo?(pascalc)
(In reply to David Bolter [:davidb] (NeedInfo me for attention) from comment #17)
> Pascal does this still need to track 63?

It's marked as wontfix for 63 so it would no longer show up in our triage queries even if marked as tracked. That said, it was tracked during the nightly cycle because the volume of crashes was much higher in July (x4) than today, given the current volume and the fact that we won't fix it for this release, we can untrack it yes.
Flags: needinfo?(pascalc)
Priority: P2 → P1
Low volume crash, marking as fix-optional and P3.

Closing because no crashes reported for 12 weeks.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.