Closed Bug 1454029 Opened 4 years ago Closed 4 years ago

Export Screenshots 32.1.0

Categories

(Firefox :: Screenshots, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 61
Tracking Status
firefox61 --- fixed

People

(Reporter: ianbicking, Assigned: ianbicking)

Details

Attachments

(3 files)

This is an export of Screenshots 32.0.0

(Note that while we're discussing new techniques to merge GitHub repositories into mozilla-central, that work is still in progress, so we'll be doing exports for a while longer yet)

Changelog is at https://github.com/mozilla-services/screenshots/blob/master/CHANGELOG.md#version-3200 (items copied below):

### Add-on changes

* Fix URL clipboard copy for certain sites. https://github.com/mozilla-services/screenshots/issues/4269 (https://github.com/mozilla-services/screenshots/commit/69683f6)
* Enable context menu icon. https://github.com/mozilla-services/screenshots/issues/3858 https://github.com/mozilla-services/screenshots/issues/4264 (https://github.com/mozilla-services/screenshots/commit/55e2475)
* Wait for onboarding status. https://github.com/mozilla-services/screenshots/issues/3954 https://github.com/mozilla-services/screenshots/issues/4263 (https://github.com/mozilla-services/screenshots/commit/abc8109)
* Fix a width so users cannot x scroll on selection frame. https://github.com/mozilla-services/screenshots/issues/3955 https://github.com/mozilla-services/screenshots/issues/4258 (https://github.com/mozilla-services/screenshots/commit/77fa083)
* Set display CSS property on iframes. https://github.com/mozilla-services/screenshots/issues/4148 https://github.com/mozilla-services/screenshots/issues/4256 (https://github.com/mozilla-services/screenshots/commit/ba4073f)
* Calculate left and top margin with left and top. https://github.com/mozilla-services/screenshots/issues/4217 (https://github.com/mozilla-services/screenshots/commit/cd36b7c)
* Standard ISO 8601 date for filename, https://github.com/mozilla-services/screenshots/issues/4199
  * Use date variable instead of newly created today variable
  * const instead of let, forgot space. Fixes https://github.com/mozilla-services/screenshots/issues/4197 Fixes https://github.com/mozilla-services/screenshots/issues/4197 (https://github.com/mozilla-services/screenshots/commit/eee880f)

#### Clean-up

* zopflipng PNGs. https://github.com/mozilla-services/screenshots/issues/4059 https://github.com/mozilla-services/screenshots/issues/4257 (https://github.com/mozilla-services/screenshots/commit/9a5699b)
* Rename asJson to toJSON. https://github.com/mozilla-services/screenshots/issues/2593 (https://github.com/mozilla-services/screenshots/commit/a2ecd83)
* Remove some code around favicon url. https://github.com/mozilla-services/screenshots/issues/2659 (https://github.com/mozilla-services/screenshots/commit/1300069)
* Use URL() to validate URLs. https://github.com/mozilla-services/screenshots/issues/2660 (https://github.com/mozilla-services/screenshots/commit/c2b02ac)
Assignee: nobody → ianb
Summary: Export Screenshots 32.0.0 → Export Screenshots 32.1.0
Additional change in 32.1.0:

* fix regression in Library link https://github.com/mozilla-services/screenshots/issues/4343 – The commit https://hg.mozilla.org/mozilla-central/diff/3182593eb59a/browser/base/content/utilityOverlay.js regressed this, requiring a principal for calls to openUILinkIn(). This changes that to the function openWebLinkIn() that provides a null principal. (https://github.com/mozilla-services/screenshots/commit/c823b10)
I ran two Try builds. The first uncovered a TV (test verification) problem: https://treeherder.mozilla.org/#/jobs?repo=try&revision=f74d74e8f8f3186b704c5769b2a3e4c9b432aa6b

I reran with a different invocation, which I thought from documentation would run less tests, but instead ran everything: https://treeherder.mozilla.org/#/jobs?repo=try&revision=18fb274f096a3612ca5ea739a4ec9a7f8fbd8a76

The TV test failures did not appear in the second run. I'm not sure I understand what happened, but my hunch is that these failures appeared because of lint-related changes to the test, which triggered TV, and the verification tests re-exposed some intermittents (Bug 1414673 and Bug 1394967), specifically on the "Linux x64 QuantumRender opt" platform.

I think it's okay to continue even with these failures, as these are known issues, they are specific to test situations, and I don't believe we've done anything that would exacerbate the problem.
Attachment #8970331 - Flags: review?(francesco.lodolo)
Comment on attachment 8970331 [details]
Bug 1454029 - Export Screenshots 32.1.0 to Firefox (translations only);

https://reviewboard.mozilla.org/r/239122/#review245144
Attachment #8970331 - Flags: review?(jhirsch) → review+
Comment on attachment 8970332 [details]
Bug 1454029 - Export Screenshots 32.1.0 to Firefox (upgrade Raven to 3.24.1);

https://reviewboard.mozilla.org/r/239124/#review245146
Attachment #8970332 - Flags: review?(jhirsch) → review+
Comment on attachment 8970333 [details]
Bug 1454029 - Export Screenshots 32.1.0 to Firefox (code excluding translations and Raven update);

https://reviewboard.mozilla.org/r/239126/#review245150
Attachment #8970333 - Flags: review?(jhirsch) → review+
Comment on attachment 8970331 [details]
Bug 1454029 - Export Screenshots 32.1.0 to Firefox (translations only);

https://reviewboard.mozilla.org/r/239122/#review245152

I'll make sure to take a look at incomplete locales, to verify that everything falls back gracefully.
Attachment #8970331 - Flags: review?(francesco.lodolo) → review+
Pushed by jhirsch@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d7d3092ca2a4
Export Screenshots 32.1.0 to Firefox (translations only); r=flod,_6a68
https://hg.mozilla.org/integration/autoland/rev/b2c06b2574ea
Export Screenshots 32.1.0 to Firefox (upgrade Raven to 3.24.1); r=_6a68
https://hg.mozilla.org/integration/autoland/rev/2fecadce382e
Export Screenshots 32.1.0 to Firefox (code excluding translations and Raven update); r=_6a68
https://hg.mozilla.org/mozilla-central/rev/d7d3092ca2a4
https://hg.mozilla.org/mozilla-central/rev/b2c06b2574ea
https://hg.mozilla.org/mozilla-central/rev/2fecadce382e
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
You need to log in before you can comment on or make changes to this bug.