Closed Bug 1454820 Opened 2 years ago Closed 2 years ago

bundled WebExtension experiments do not work for SIGNEDSTATE_SYSTEM

Categories

(WebExtensions :: Experiments, enhancement, P1)

enhancement

Tracking

(firefox60 wontfix, firefox61+ fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox60 --- wontfix
firefox61 + fixed

People

(Reporter: rhelmer, Assigned: jkt)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

Comment on attachment 8968708 [details]
Bug 1454820 - Add support for system addon signing for web extension bundling.

https://reviewboard.mozilla.org/r/237414/#review243196

Sorry for the drive-by but I don't think this is enough.  This will enable system addon updates, but not system addons that are distributed with the app in the features directory.
Assignee: rhelmer → jkt
Duplicate of this bug: 1442803
n-i on myself to remember to check up on this tomorrow.
Flags: needinfo?(lhenry)
Comment on attachment 8968708 [details]
Bug 1454820 - Add support for system addon signing for web extension bundling.

https://reviewboard.mozilla.org/r/237414/#review245342

Looks fine to me, should probably be sure to get Kris' approval, too.
Attachment #8968708 - Flags: review?(jhofmann) → review+
Kris, do you think this is ready to land? Are you aiming at 61 here, or at 60?
Flags: needinfo?(lhenry) → needinfo?(kmaglione+bmo)
Comment on attachment 8968708 [details]
Bug 1454820 - Add support for system addon signing for web extension bundling.

https://reviewboard.mozilla.org/r/237414/#review245906
Attachment #8968708 - Flags: review?(kmaglione+bmo) → review+
Priority: -- → P1
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #10)
> Kris, do you think this is ready to land? Are you aiming at 61 here, or at
> 60?

Yes, I think so. I think we can aim for 61 at this point, unless anyone thinks we're very likely to need to ship system extensions with bundled experiments on 60. The issues that would have originally justified an uplift have been resolved.

It is a very low-risk patch, though.
Flags: needinfo?(kmaglione+bmo)
Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8141b60030b9
Add support for system addon signing for web extension bundling. r=johannh,kmag
This fail seems very unrelated and it also looks like another backout happened to solve the same error in Bug 1457287. Can we try landing this again?
Flags: needinfo?(jkt) → needinfo?(csabou)
Pushed by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7e3aa63ae752
Add support for system addon signing for web extension bundling. r=johannh,kmag
Marked for landing after other commits landed broke the complexity of this function.
Flags: needinfo?(jkt)
Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5e8342edb62d
Add support for system addon signing for web extension bundling. r=johannh,kmag
None of those seem relevant, these are all DOM tests? Was there anything else that seemed closer to extensions?

I don't recognise any of these whilst I was building this patch.

Thanks!
Flags: needinfo?(jkt) → needinfo?(csabou)
Crap I merged another patch in whilst trying to rush this out the door. I understand now sorry. Will fix now!
Flags: needinfo?(jkt)
I requested for landing again after removing the other patch which got merged in by mistake. I got a clean try run, especially not including any of the mentioned dom issues from the previous.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=7b491c5fc8b8837804892e5247969f65f7eabfd9
Pushed by jkingston@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa02de71ebf7
Add support for system addon signing for web extension bundling. r=johannh,kmag
https://hg.mozilla.org/mozilla-central/rev/fa02de71ebf7
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
wontfix for 60 based on comment 12. Is this something QE should verify?
Flags: needinfo?(jkt)
Depends on: 1457718
I think this is fine without verifying at this point given the tests we have.
Flags: needinfo?(jkt)
Flags: qe-verify-
Set to "Flags: qe-verify-" as per https://bugzilla.mozilla.org/show_bug.cgi?id=1454820#c31.
Depends on: 1467113
Product: Toolkit → WebExtensions
Depends on: 1496150
You need to log in before you can comment on or make changes to this bug.