Remove createObjectURL()'s MediaStream overload

RESOLVED FIXED in Firefox 62

Status

()

enhancement
P2
normal
RESOLVED FIXED
Last year
3 months ago

People

(Reporter: annevk, Assigned: baku)

Tracking

(Blocks 1 bug, {dev-doc-complete, site-compat})

unspecified
mozilla62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

Last year
Per https://w3c.github.io/mediacapture-main/ this was removed in 2013 from the standard, but we appear to still implement it. Safari does throw.
Assignee

Comment 2

Last year
The warning message landed 1 year ago, in Firefox 54. I think it's time to remove this method.
Reporter

Updated

Last year
Keywords: dev-doc-needed
Assignee

Comment 3

Last year
Assignee: nobody → amarchesini
Attachment #8969702 - Flags: review?(valentin.gosu)
Attachment #8969702 - Flags: review?(valentin.gosu) → review+

Comment 4

Last year
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c5a4939300c
Remove createObjectURL()'s MediaStream overload, r=valentin
https://hg.mozilla.org/mozilla-central/rev/0c5a4939300c
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61

Comment 7

Last year
Backout by nbeleuzu@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/fb435df9797a
Backed out changeset 0c5a4939300c for causing frequent Leaks (Bug 1378025). a=backout
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla61 → ---

Comment 9

Last year
Pushed by nbeleuzu@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/43e0ab28dfe2
Re-add expected fail mediacapture-streams/historical.html after backout. a=wpt-fix
Priority: -- → P2
Depends on: 1378025
You should be able to reland now. Note that WPT needs an additional unexpected-pass fix, per https://treeherder.mozilla.org/#/jobs?repo=try&revision=b568e34493797742ad83deea0a439cdda9dbf4ce&selectedJob=178302962

Comment 11

Last year
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1076e77e7b5c
Remove createObjectURL()'s MediaStream overload, r=valentin
https://hg.mozilla.org/mozilla-central/rev/1076e77e7b5c
Status: REOPENED → RESOLVED
Closed: Last yearLast year
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Assignee

Updated

Last year
Flags: needinfo?(amarchesini)

Updated

11 months ago
Depends on: 1480681
Duplicate of this bug: 1489300
Assignee

Comment 16

9 months ago
This issue has been discussed on dev-platform. I didn't know when Chrome was planning to deprecate this feature.
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.