Closed Bug 14558 Opened 21 years ago Closed 21 years ago

pkgcp.pl doesn't seem to be correctly copying wildcards

Categories

(SeaMonkey :: Build Config, defect, P3)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: leaf, Assigned: granrosebugs)

References

Details

(Whiteboard: workaround in place)

I'm seeing this with perl 5.005_02, activestate (which has the modules pkgcp.pl
seems to require), windows NT.

What appears to be happening is that destination folder names get created in the
*source* directory as do_copy() descends.

I'm not sure how $Find::File:: works, though. i'll keep poking.
Status: NEW → ASSIGNED
worked with leaf on this today.  updated pkgcp.pl works the same as one in tree.

main problem appears to be that the destdir is losing its drive and leading
slash so d:\foo\bar becomes foo\bar.  this appears to be related to the
environment since it works fine on the verification system.  still unclear what
the root cause is.
Whiteboard: workaround in place
leaf did some more investigation of this, and we found that the root cause was
that the destination directory was a subdirectory of the source directory.  e.g.
srcdir = d:\foo, destdir = d:\foo\bar.  This was failing on wildcard copies of
directories because the filename returned by the find includes the entire source
directory path.  We strip this out to create the destination directory path and
so it was stripping out the d:\foo and the destination directory became "bar"
and remained in the source directory.

The workaround is to not allow a destdir to be a subdir of the srcdir, so I
have updated the help text and am adding that test to the code along with a
comment to fix it in the future.

This bug can probably be closed, but I'm leaving it open for now as a reminder.
Blocks: 12567
Hardware: PC → All
fix checked in, closing.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.