Closed Bug 1456400 Opened 2 years ago Closed 2 years ago

Intermittent TEST-UNEXPECTED-TIMEOUT | /webdriver/tests/close_window/user_prompts.py | expected OK

Categories

(Testing :: geckodriver, defect, P5)

Version 3
defect

Tracking

(firefox61 fixed)

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: janv)

References

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][wptsync upstream])

Attachments

(1 file)

Filed by: shindli [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=175271063&repo=autoland

https://queue.taskcluster.net/v1/task/U34zpUZgTaK_KmRq3ojz6g/runs/0/artifacts/public/logs/live_backing.log

06:00:20     INFO -  Buffered messages logged at 05:55:21
06:00:20     INFO -  57 INFO got stalled event
06:00:20     INFO -  Buffered messages finished
06:00:20    ERROR -  58 INFO TEST-UNEXPECTED-FAIL | dom/media/mediasource/test/test_FrameSelection_mp4.html | Test timed out.
06:00:20     INFO -      reportError@SimpleTest/TestRunner.js:121:7
06:00:20     INFO -      TestRunner._checkForHangs@SimpleTest/TestRunner.js:142:7
The reference in comment 0 is wrong. So here an update which shows that the failure is actually again a shutdown hang of Firefox:

[task 2018-04-24T07:00:31.762Z] 07:00:31     INFO - PID 1194 | 1524553231753   
Marionette    TRACE    0 -> [0,12,"Marionette:Quit",{"flags":["eForceQuit"]}]
[task 2018-04-24T07:00:31.763Z] 07:00:31     INFO - PID 1194 | 1524553231754   
Marionette    TRACE    0 <- [1,12,{"error":"invalid session
id","message":"","stacktrace":"WebDriverError@chrome://marionette/content/error.js:178:5\nInv
...
et@chrome://marionette/content/server.js:245:8\n_onJSONObjectReady/<@chrome://marionette/content/transport.js:500:9\n"},null]
[task 2018-04-24T07:00:31.764Z] 07:00:31     INFO - PID 1194 | 1524553231754   
geckodriver::marionette    TRACE    <- [1,12,{"error":"invalid session
id","message":"","stacktrace":"WebDriverError@chrome://marionette/content/error.js:178:5\nInvalidSessionIDError@chrome://marionette/content/error.js:347:5\nassert.that/<@chrome://marionette/content/assert.js:405:13\nassert.session@chrome://marionette/content/assert.js:79:3\ndespatch@chrome://marionette/content/server.js:294:7\nasync*execute@chrome://marionette/content/server.js:271:11\nasync*onPacket/<@chrome://marionette/content/server.js:246:15\nasync*onPacket@chrome://marionette/content/server.js:245:8\n_onJSONObjectReady/<@chrome://marionette/content/transport.js:500:9\n"},null]
[task 2018-04-24T07:00:31.782Z] 07:00:31     INFO - PID 1194 | 1524553231771   
Marionette    DEBUG    Closed connection 0
[task 2018-04-24T07:00:57.853Z] 07:00:57     INFO - TEST-UNEXPECTED-TIMEOUT |
/webdriver/tests/close_window/user_prompts.py | expected OK

So nothing we can do here right now. If it fails only intermittently we can
land, otherwise we might have to temporarily mark it as disabled.
Depends on: 1455282, 1449538
This is a new test as added by that push, right. Given that it fails that much, and we do not see a crash report due to the shutdown hang of Firefox, a good idea would be to increase the timeout of the test. At least then we might have a chance to see a crash as caused by the hang reporter.
Flags: needinfo?(hskupin)
Given that it continuous to have a high failure rate I will come up with a patch later today which requests a longer timeout for this test.
The try build looks fine and I'm going to increase the timeout now.
Attachment #8971547 - Flags: review?(hskupin)
Comment on attachment 8971547 [details]
Bug 1456400 - [wdspec] Increase timeout for close_window/user_prompts.py test.

https://reviewboard.mozilla.org/r/240300/#review246098
Attachment #8971547 - Flags: review?(hskupin) → review+
We have to leave this bug open until bug 1449538 has been fixed.
Keywords: leave-open
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b27cb10f8110
[wdspec] Increase timeout for close_window/user_prompts.py test. r=whimboo
Whiteboard: [retriggered] → [retriggered][wptsync upstream error]
Fixed by bug 1449538. I will keep the longer timeout present for now.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
Assignee: nobody → hskupin
Keywords: leave-open
It was actually Jan who fixed the underlying shutdown hang in QuotaManager.
Assignee: hskupin → jvarga
Created web-platform-tests PR https://github.com/w3c/web-platform-tests/pull/10941 for changes under testing/web-platform/tests
Whiteboard: [retriggered][wptsync upstream error] → [retriggered][wptsync upstream]
Upstream PR merged
You need to log in before you can comment on or make changes to this bug.