Closed Bug 1456452 Opened 5 years ago Closed 3 years ago

[CSD] Calculate correct window offset for Gtk+ < 3.20

Categories

(Core :: Widget: Gtk, enhancement, P3)

60 Branch
Unspecified
Linux
enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: stransky, Unassigned)

References

(Blocks 1 open bug)

Details

This is follow up from Bug #1441665

UpdateClientOffsetForCSDWindow() works correctly for Gtk+ >= 3.20 as it provides gtk_render_background_get_clip().

We can use gdk_window_get_origin()/gdk_window_get_root_origin() to get the correct offset but it works for visible GdkWindow only.
Assignee: nobody → stransky
Duplicate of this bug: 1457438
Good example is Linux Mint 18.3 Mate.
Summary: Calculate correct window offset for Gtk+ < 3.20 → [CSD] Calculate correct window offset for Gtk+ < 3.20

Giving back, I have no intention to work on that right now.

Assignee: stransky → nobody
Priority: P2 → P3
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.