[CSD][Maximized window] when Title Bar is disabled, page elements and popups are drawn in the wrong location at

RESOLVED FIXED in Firefox 61

Status

()

defect
P1
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla61
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox61 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
This is a variant of Bug #1441665 for maximized window state.

When toplevel window is maximized there's no decoration offset/margin at toplevel window so we need to update client offset accordingly.
(Assignee)

Updated

a year ago
See Also: → 1441665
(Assignee)

Updated

a year ago
See Also: → 1456898
(Assignee)

Updated

a year ago
Priority: -- → P1

Comment 2

a year ago
mozreview-review
Comment on attachment 8971505 [details]
Bug 1457309 - [Gtk+/CSD] Reset toplevel window offset when it's at maximized/fulscreenstate,

https://reviewboard.mozilla.org/r/240268/#review246070
Attachment #8971505 - Flags: review?(jhorak) → review+

Comment 3

a year ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/61ef04097971
[Gtk+/CSD] Reset toplevel window offset when it's at maximized/fulscreenstate, r=jhorak

Comment 4

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/61ef04097971
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61

Updated

a year ago
Duplicate of this bug: 1461029

Updated

11 months ago
Duplicate of this bug: 1462271
You need to log in before you can comment on or make changes to this bug.