Right Clicking for Context Menu Immediately Returns the Browser to Previous Page When Title Bar is Disabled

RESOLVED DUPLICATE of bug 1457309

Status

()

defect
RESOLVED DUPLICATE of bug 1457309
a year ago
a year ago

People

(Reporter: nathan, Unassigned)

Tracking

60 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME?])

Attachments

(1 attachment)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180503143129

Steps to reproduce:

I right clicked on a web page to bring up the context menu and the browser immediately sent me to the previous page. As if I clicked the Back button on the context menu, however, I did not click the button. I only right clicked.

This only happens after disabling the new Title Bar from the customize menu.


Actual results:

The browser returned to the previous page.


Expected results:

The right click context menu should have displayed.

Updated

a year ago
Blocks: gtktitlebar
Has STR: --- → yes
Component: Untriaged → Widget: Gtk
OS: Unspecified → Linux
Product: Firefox → Core
Hardware: Unspecified → x86_64

Comment 1

a year ago
This is probably because the menu is misplaced in FF60, it is fixed in Nightly though.  Probably a dupe of https://bugzilla.mozilla.org/show_bug.cgi?id=1457309

Comment 2

a year ago
Reporter, please check if the problem occurs in the latest Nightly with a brand new profile.
https://www.mozilla.org/firefox/nightly/all/
https://support.mozilla.com/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(nathan)
Whiteboard: [DUPEME?]
(Reporter)

Comment 3

a year ago
(In reply to Gingerbread Man from comment #2)
> Reporter, please check if the problem occurs in the latest Nightly with a
> brand new profile.
> https://www.mozilla.org/firefox/nightly/all/
> https://support.mozilla.com/kb/profile-manager-create-and-remove-firefox-
> profiles

I downloaded the nightly for today 05-14-2018 and I no longer see the problem. Thank you!
Flags: needinfo?(nathan)

Comment 4

a year ago
Thank you for the update.
No longer blocks: gtktitlebar
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457309
You need to log in before you can comment on or make changes to this bug.