Closed Bug 1457763 Opened 2 years ago Closed 2 years ago

regression: incorrectly placed autoscroll icon

Categories

(Core :: XUL, defect, P1, blocker)

defect

Tracking

()

VERIFIED FIXED
mozilla61
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 --- unaffected
firefox59 --- unaffected
firefox60 --- unaffected
firefox61 blocking verified

People

(Reporter: darkspirit, Assigned: enndeakin)

References

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Debian Testing, KDE, Xorg, Radeon RX480, 2560x1440
Gtk3 Breeze Theme
libgtk-3-0:amd64 3.22.29-3
KDE Plasma 5.12.4
KDE Framework 5.44.0
QT 5.10.1

Actual:
The autoscroll icon shows up about a centimeter below the cursor.

When snapping Nightly to the right half of the window the autoscroll icon is not only a few pixels too far down, but also on the outer right side, directly next to the scrollbar.

Only the autoscroll icon is affected. Context menu and <select> dropdowns seem to be fine.

Expected:
The center of the autoscroll icon should be where the cursor points to.

mozregression --good 2018-04-28 --bad 2018-04-29 --pref browser.tabs.drawInTitlebar:false general.autoScroll:true startup.homepage_welcome_url:'https://www.mozilla.org/de/'
> 6:49.44 INFO: Last good revision: f846639066aa8f7e5aff7fa363a450885fc887b4
> 6:49.44 INFO: First bad revision: 19b49df2389f777dd45779d89a3f83046c40b3d6
> 6:49.44 INFO: Pushlog:
> https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=f846639066aa8f7e5aff7fa363a450885fc887b4&tochange=19b49df2389f777dd45779d89a3f83046c40b3d6

> 19b49df2389f	Neil Deakin — Bug 1446961, move PopupBoxObject to XULPopupElement, a new subclass of XULElement. Remove popup.xml methods, r=paolo,bz
> 12e768652a88	Neil Deakin — Bug 1446961, add two special cases in PopupBoxObject as supported in popup.xml, r=paolo,bz
> 46d7f3cc7102	Neil Deakin — Bug 1446961, add dictionary second argument directly to PopupBoxObject::OpenPopup as supported in popup.xml#openPopup, r=bz
> 962c081b1314	Neil Deakin — Bug 1446961, remove unused popup frame methods now that showPopup has been removed, r=paolo
> 5659ad69e145	Neil Deakin — Bug 1446961, remove deprecated showPopup method of PopupBoxObject as well as unused GetPopupSetFrame method, and move some methods' positions to group related methods together better, r=paolo,bz
> 5be83a2594fb	Neil Deakin — Bug 1446961, restructuring to allow nsXULElement to be subclassed. Rename nsXULElement::Create to make it clearer it creates from the prototype element, r=bz
> e872787876a5	Neil Deakin — Bug 1446961, remove obsolete calls to showPopup and replace usages of the popup box object with the same methods defined on popups, r=paolo
(FYI: bug 1457691: After maximizing the window, also context menu and <select> dropdowns are misplaced. This can be fixed by  pressing F11 twice.)
See Also: → 1457691
Mozregression points to your changes. Could you take a look, please?
Win10 has the same regression range.
Has Regression Range: --- → yes
Flags: needinfo?(enndeakin)
OS: Linux → All
Hardware: x86_64 → All
This is worse on RTL locales- there, the autoscroll icon is located at the far left of the screen.
See attached.
Attached image Screenshot
This sounds pretty bad for people experiencing it.
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Flags: needinfo?(enndeakin)
Attachment #8972344 - Flags: review?(paolo.mozmail)
Comment on attachment 8972344 [details] [diff] [review]
autoscroll popup should be opened with openPopupAtScreen

Thanks!
Attachment #8972344 - Flags: review?(paolo.mozmail) → review+
Duplicate of this bug: 1458025
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/76855675e353
regression, autoscroll popup should be opened with openPopupAtScreen, r=paolo
Severity: normal → blocker
Flags: qe-verify+
Priority: -- → P1
https://hg.mozilla.org/mozilla-central/rev/76855675e353
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
(In reply to Pulsebot from comment #9)
> Pushed by neil@mozilla.com:
> https://hg.mozilla.org/integration/mozilla-inbound/rev/76855675e353
> regression, autoscroll popup should be opened with openPopupAtScreen, r=paolo

Nightly 61 x64 20180502220059 de_DE 2d83e1843241d869a2fc5cf06f96d3af44c70e70 @ Debian Testing, KDE, Radeon RX480
Thank you! The autoscroll icon is now correctly placed in a maximized and non-maximized window with browser.tabs.drawInTitlebar=true and false.

Offtopic: The misplaced bookmarks menu is tracked in bug 1457110.
Status: RESOLVED → VERIFIED
Managed to reproduce the issue on the Nightly (build ID: 20182502100112 / 2018-05-02) on  Windows 10 x64, Mac OS X 10.12 and Ubuntu 16.04 x64.

In the latest Nightly (including builds with RTL locales) the issue cannot be reproduced on Windows 10 x64, Mac OS X 10.12 and Ubuntu 16.04 x64, thus I will close the issue as VERIFIED FIXED.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.