Closed Bug 1458025 Opened 2 years ago Closed 2 years ago

The autoscroll direction indicator is drawn drastically offset from the mouse position on Linux Nightly

Categories

(Core :: XUL, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1457763
Tracking Status
firefox61 --- affected

People

(Reporter: cks+mozilla, Unassigned)

References

Details

Normally when you autoscroll, the autoscroll direction indicator is drawn at your starting mouse position. On Linux Nightly, it is now drawn significantly offset from this position; how much offset seems to depend on how far from the top left corner the mouse position is when you start the autoscroll. On my display (two 1920x1200 panels side by side), it can easily be far outside the Firefox window.

(By the autoscroll direction indicator I mean the grey icon that appears with directional arrows to tell you which directions you can autoscroll in by moving the mouse.)

My environment is Fedora 27, x86_64, AMD Radeon graphics, under X (not Wayland), and my displays are not HiDPI. This is a recent change but I have yet to go hunting for the specific breakage point.
Bisection shows that this is a regression from bug 1446961.

Steps to reproduce (Linux, Windows at least):
Middleclick somewhere on unlinked content.

Actual result: Autoscroll indicator offset to the right.

Expected result: Autoscroll indicator shown at click position.
Blocks: 1446961
Component: Widget: Gtk → XUL
Flags: needinfo?(enndeakin)
Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(enndeakin)
Resolution: --- → DUPLICATE
Duplicate of bug: 1457763
You need to log in before you can comment on or make changes to this bug.