Closed Bug 1458174 Opened 2 years ago Closed 2 years ago

Remove nsIDOMElement from SeaMonkey

Categories

(SeaMonkey :: General, enhancement, P2)

All
Unspecified
enhancement

Tracking

(seamonkey2.57esr unaffected, seamonkey2.58 fixed)

RESOLVED FIXED
seamonkey2.58
Tracking Status
seamonkey2.57esr --- unaffected
seamonkey2.58 --- fixed

People

(Reporter: frg, Assigned: frg)

References

(Blocks 1 open bug)

Details

Attachments

(2 files, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #1455674 +++

nsIDOMElement has been removed. Tree is broken for all platforms because of this.
Attached patch 1458174-nsIDOMElement.patch (obsolete) — Splinter Review
Compile is running
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attached patch 1458174-nsIDOMElement.patch (obsolete) — Splinter Review
Rebased. macOS and Windows compile. Can't test Linux currently.
Attachment #8972273 - Attachment is obsolete: true
Attachment #8972382 - Flags: review?(iann_bugzilla)
nsGNOMEShellService.cpp was missing a "namespace mozilla" declaration. No other changes.
Attachment #8972382 - Attachment is obsolete: true
Attachment #8972382 - Flags: review?(iann_bugzilla)
Attachment #8972549 - Flags: review?(iann_bugzilla)
Comment on attachment 8972549 [details] [diff] [review]
1458174-nsIDOMElement-V2.patch

LGTM r=me
Attachment #8972549 - Flags: review?(iann_bugzilla) → review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/e6f416a808eb
Remove nsIDOMElement from SeaMonkey. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Seamonkey2.58
Duplicate of this bug: 1475874

Bill found an error in the original patch. r+ from me.

Attachment #9131860 - Flags: review+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/3fd01064df4a
Remove nsIDOMElement from SeaMonkey. r=frg
You need to log in before you can comment on or make changes to this bug.