Closed Bug 1458303 Opened Last year Closed Last year

Provide fix to Firefox to prevent TDR on Windows 7 with bugged NVIDIA GPU drivers (397.40 & 397.76) on Pascal GPUs

Categories

(Core :: Graphics, defect, P3, critical)

57 Branch
All
Windows 7
defect

Tracking

()

VERIFIED FIXED
mozilla62
Tracking Status
firefox-esr52 --- unaffected
firefox-esr60 61+ verified
firefox59 --- wontfix
firefox60 + wontfix
firefox61 + verified
firefox62 + verified

People

(Reporter: Virtual, Assigned: bas.schouten)

References

Details

(Keywords: crash, nightly-community, Whiteboard: [gfx-noted])

Follow up of bug #1433058 and bug #1419264.

Please add NVIDIA GPU drivers 397.40 (branch: 396_42-32) [ https://developer.nvidia.com/vulkan-driver ] to blacklist, as they are based on older branch without real fix for bug #1433058 and bug #1419264 included in NVIDIA GPU drivers 397.31 (branch: 397_05-13).
Flags: needinfo?(bas)
Has Regression Range: --- → irrelevant
Has STR: --- → irrelevant
Assignee: nobody → bas
Possibly too late for Fx60 (we're already building release candidate builds), but worth keeping on the radar as a ride-along fix should the opportunity arise.
FYI - new hotfix NVIDIA GPU drivers 397.55 (branch: 397_05-20) [ https://nvidia.custhelp.com/app/answers/detail/a_id/4661 ] are unaffected by TDRs issue per newer branch than NVIDIA GPU drivers 397.40 (branch: 396_42-32) [ https://developer.nvidia.com/vulkan-driver ].

So:
NVIDIA GPU drivers 397.31 (branch: 397_05-13) <= first non-buggy driver on new branch
NVIDIA GPU drivers 397.40 (branch: 396_42-32) <= still buggy per older branch + have to be blacklisted
NVIDIA GPU drivers 397.55 (branch: 397_05-20) <= second non-buggy driver on new branch
As problematic as the 397.31 drivers were, we could probably just blocklist <397.55 and get on with life.
397.64 WHQL were released the other day. I haven't had any issues prior to 397.31 myself but perhaps new new version will help folks with residual issues?
(In reply to Ryan VanderMeulen [:RyanVM] from comment #3)
> As problematic as the 397.31 drivers were, we could probably just blocklist
> <397.55 and get on with life.

Not so fast, as there are new NVIDIA GPU drivers 397.76 (branch: 396_42-37) [ https://developer.nvidia.com/vulkan-driver ], despite "Pick up the latest fixes from general release driver 397.64" in changelog, these drivers don't have fix for "[Media Player Classic Home Cinema]: When launching a video, the system stutters momentarily [2070328]" as it still occurring in my case, so they're probably bugged as well.

So:
NVIDIA GPU drivers 397.31 (branch: 397_05-13) <= first non-buggy driver on new branch
NVIDIA GPU drivers 397.40 (branch: 396_42-32) <= still buggy per older branch + have to be blacklisted
NVIDIA GPU drivers 397.55 (branch: 397_05-20) <= second non-buggy driver on new branch
NVIDIA GPU drivers 397.64 (branch: 397_05-25) <= third non-buggy driver on new branch
NVIDIA GPU drivers 397.76 (branch: 396_42-37) <= probably still buggy per older branch + have to be blacklisted
Summary: Provide fix to Firefox to prevent TDR on Windows 7 with bugged NVIDIA GPU drivers (397.40) on Pascal GPUs → Provide fix to Firefox to prevent TDR on Windows 7 with bugged NVIDIA GPU drivers (397.40 & 397.76) on Pascal GPUs
I'm having a hard time caring about Beta Vulkan drivers. Do we really expect those to be widely in use?
Vulkan developer beta drivers are for developers for testing latest Vulkan 1.1 features added by Nvidia, they are not mainline Nvidia drivers and user base is very low compared to the latest 397.64 driver on Nvidia's website which used by everyone. You should just ignore the Vulkan developer beta drivers.
(In reply to Ryan VanderMeulen [:RyanVM] from comment #6)
> I'm having a hard time caring about Beta Vulkan drivers. Do we really expect
> those to be widely in use?

Firefox telemetry could come in handy in this case.
* Bug 1457758 blocklisted version 397.31 across all Windows versions (and was uplifted to Fx61 and ESR60).
* nVidia has released multiple official 397 updates since then off the fixed codebase.
* None of the 397 versions register high on the list of nVidia driver versions for Win7 or Win10 according to our Telemetry data, let alone any of the buggy versions from comment 5 (which are non-existent as I think we suspected they would be).

All of that said, I think we're done here.
Status: ASSIGNED → RESOLVED
Closed: Last year
Depends on: 1457758
Flags: needinfo?(bas)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.