crash when print previewing www.robinlionheart.com/stds/html4/tables.html

VERIFIED FIXED in mozilla1.0.1

Status

()

Core
Layout: Tables
P1
critical
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: karnaze (gone), Assigned: karnaze (gone))

Tracking

({crash, testcase})

Trunk
mozilla1.0.1
x86
Windows 2000
crash, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: PATCH [adt2 rtm][ETA 06/26], URL)

Attachments

(2 attachments)

(Assignee)

Description

16 years ago
 
(Assignee)

Updated

16 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Priority: -- → P1
Target Milestone: --- → mozilla1.0.1

Updated

16 years ago
Keywords: crash

Comment 1

16 years ago
Same with 2002052008/trunk/W2K in Print Preview -> TB6493889X
(Assignee)

Updated

16 years ago
Summary: crash when print previewing www.robinlionheart.com/stds/html4/tables.html (border collapse) → crash when print previewing www.robinlionheart.com/stds/html4/tables.html
(Assignee)

Comment 2

16 years ago
Created attachment 84478 [details]
reduced test case
(Assignee)

Comment 3

16 years ago
Created attachment 84481 [details] [diff] [review]
patch to fix the bug
(Assignee)

Updated

16 years ago
Whiteboard: PATCH
(Assignee)

Comment 4

16 years ago
Adding nsbeta1 keyword. This patch is very low risk and will prevent a crash 
whenever a thead or tfoot gets split.
Keywords: nsbeta1
nsbeta1+
Keywords: nsbeta1 → nsbeta1+
Whiteboard: PATCH → PATCH [adt2]

Comment 6

16 years ago
 Adding testcase keyword.
Keywords: testcase

Comment 7

16 years ago
Comment on attachment 84481 [details] [diff] [review]
patch to fix the bug

sr=attinasi
Attachment #84481 - Flags: superreview+

Comment 8

16 years ago
Comment on attachment 84481 [details] [diff] [review]
patch to fix the bug

r= alexsavulov
Attachment #84481 - Flags: review+

Updated

16 years ago
Whiteboard: PATCH [adt2] → PATCH [adt2 rtm]
(Assignee)

Comment 9

16 years ago
FIXED_ON_TRUNK
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Whiteboard: PATCH [adt2 rtm] → PATCH [adt2 rtm][FIXED_ON_TRUNK]

Comment 10

16 years ago
 verified on trunk build 2002060408. But the bug still exits on branch build.
Whiteboard: PATCH [adt2 rtm][FIXED_ON_TRUNK] → PATCH [adt2 rtm][FIXED_ON_TRUNK][VERIFIED_ON_TRUNK]
(Assignee)

Comment 11

16 years ago
*** Bug 146597 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Keywords: adt1.0.1, approval, mozilla1.0.1

Comment 12

16 years ago
Resolving as verified per Comment #10 From Amarendra Hanumanula  
Status: RESOLVED → VERIFIED

Comment 13

16 years ago
Marking adt1.0.1+ on behalf of the adt for checkin to the 1.0 branch.  Please
get drivers approval before checking in.
Keywords: adt1.0.1 → adt1.0.1+

Comment 14

16 years ago
please checkin to the 1.0.1 branch. once there, remove the "mozilla1.0.1+"
keyword and add the "fixed1.0.1" keyword.
Keywords: mozilla1.0.1 → mozilla1.0.1+

Comment 15

16 years ago
This was approved for the branch last week. When can someone land the fix on the
branch?
Whiteboard: PATCH [adt2 rtm][FIXED_ON_TRUNK][VERIFIED_ON_TRUNK] → PATCH [adt2 rtm][ETA 06/26]
(Assignee)

Comment 16

16 years ago
This landed on the branch a couple of days ago.
Keywords: mozilla1.0.1+ → fixed1.0.1

Comment 17

16 years ago
 Verified on branch build: 2002-07-11-08-1.0 on WIN2K. Does not crash any more 
when I print Preview the given URL.
Keywords: verified1.0.1

Updated

15 years ago
Blocks: 41368
You need to log in before you can comment on or make changes to this bug.