Bug 41368 (robin's)

Fails test cases in Robin's HTML 4.0 Conformance Test

RESOLVED WONTFIX

Status

Core Graveyard
Tracking
P3
normal
RESOLVED WONTFIX
18 years ago
a year ago

People

(Reporter: Shane Clements, Assigned: Robin Lionheart)

Tracking

(Depends on: 3 bugs, {html4, meta, qawanted})

Trunk
html4, meta, qawanted
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (py8ieh:investigate more), URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)
BuildID:    2000060208

There are many tests on this page with code examples that fail.  A few of them 
are for the 'object' tag.

Reproducible: Always
Steps to Reproduce:
just go to http://www.robinlionheart.com/stds/html4.html
If there are many, unrelated, tests that fail, then this needs to be split up
into many bugs.  There should be one bug per issue.  (A single issue could span
multiple tests, but not the whole test page.)

When filing additional bugs:
 * Please check for duplicates.  Many of the bugs are probably already filed.
 * Note additional bugs filed or existing bugs already covered here.

Perhaps they should be marked as dependencies and this bug can be used as a
tracking bug?
Keywords: html4, qawanted

Comment 2

17 years ago
I've reported all of the bugs that show up on this page that haven't already
been reported, for the build 2000060520 on Linux; the all have pointers back
to this bug.
The pointers really should be dependencies -- this bug should depend on the 
other bugs. That way we can easily keep track of what is going on.

Also, this bug should be assigned to QA...
Blocks: 7954
Keywords: meta
Whiteboard: (py8ieh:investigate more)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
Re-assigning this bug to petersen based on Ian's comment as part of triaging 
clayton's bug list.  Please pass this on to the right QA person.  Thanks.
Assignee: clayton → petersen

Comment 5

17 years ago
I searched for the bugs Matthew (matt@nightrealms.com) was talking about,
and came up with the following two matches:

1) bug 41778 "Quotation characters for different languages should be used",
   a dup of bug 16206 "Initial value for 'quotes' property could be nicer"
   which is (like this bug) is a direct child of the HTML4 meta bug 7954.

2) bug 41781 "Image map done with OBJECT tag doesn't show"
   which ``Looks like its fixed.'' according to Matthew.
bug 41781 is now VERIFIED FIXED. Is this bug really needed?

Comment 7

17 years ago
massive update for QA contact.
QA Contact: petersen → lorca
(Assignee)

Comment 8

17 years ago
Adding dependencies to 9100 and 24113, both of whose URLs are set to pages in
this test suite.
Depends on: 9100, 24113
(Assignee)

Comment 9

17 years ago
Although I wrote the test pages referred, I didn't have anything to do with
Shane's submission. I only just noticed it today.

But as long as it's here, I may as well use it to track the bugs illustrated by
my test pages.
Severity: major → normal
Depends on: 9101, 24112, 24130
(Assignee)

Updated

17 years ago
Depends on: 9121, 16206, 37862, 41781

Comment 10

17 years ago
Do we really need a META bug for this? The problems on this page are being
tracked in other bugs (as they should be). Recommending INVALID.
(Assignee)

Updated

17 years ago
Depends on: 40545
(Assignee)

Updated

17 years ago
Depends on: 2212
(Assignee)

Updated

17 years ago
Depends on: 959

Comment 11

17 years ago
Changing to clayton@netscape.com
Assignee: petersen → clayton
XML/DOM team's turn to triage Clayton's list.
Assignee: clayton → harishd
(Assignee)

Updated

17 years ago
(Assignee)

Updated

17 years ago
Depends on: 4060
No longer depends on: 24130

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
(Assignee)

Comment 14

17 years ago
Write more descriptive summary
Summary: fails html4 test cases on this conformance test page → [META] Fails test cases in Robin's HTML 4.0 Conformance Test
Taking bug as per decision with Harish.
Assignee: harishd → ian
Status: ASSIGNED → NEW
HTML Element, -> Gerardo
Assignee: ian → gerardok

Comment 17

17 years ago
qa contact updated.
QA Contact: gerardok → bsharma

Comment 18

17 years ago
The failures described in this bug report have been entered in separate bug 
reports. If anyone is interested on tracking these, please assign this bug 
report to yourself. Otherwise, it'll be closed as Invalid.

Also, this is a meta bug. Its target milestone cannot be set earlier than the 
bugs it tracks. Removing the target milestone value.
Target Milestone: mozilla0.9 → ---

Comment 19

16 years ago
959 and this bug aren't related.
No longer depends on: 959

Updated

16 years ago
Depends on: 959
(Assignee)

Comment 20

16 years ago
The HTML side of bug 959 was related, though that half has been completed.
(Assignee)

Updated

16 years ago
Depends on: 1996
(Assignee)

Updated

16 years ago
Depends on: 88512

Updated

16 years ago
No longer depends on: 959
(Assignee)

Updated

16 years ago
Depends on: 93392
(Assignee)

Updated

16 years ago
Depends on: 3687
No longer depends on: 93392
Depends on: 28293
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

16 years ago
QA Contact: bsharma → moied
->Tracking
Component: Layout → Tracking
(Assignee)

Updated

15 years ago
Alias: robin's
(Assignee)

Updated

15 years ago
Depends on: 40680
(Assignee)

Updated

15 years ago
Depends on: 915
(Assignee)

Updated

14 years ago
Depends on: 24861, 25142
(Assignee)

Comment 23

14 years ago
Reassigning to myself per comment #18.
Assignee: gerardok → bugzilla
(Assignee)

Comment 24

14 years ago
Also note related bug #55623
(Assignee)

Updated

14 years ago
Depends on: 209424
(Assignee)

Updated

14 years ago
Depends on: 107712
(Assignee)

Updated

14 years ago
Depends on: 145842
(Assignee)

Updated

14 years ago
Depends on: 178830
(Assignee)

Updated

14 years ago
Depends on: 59070
(Assignee)

Updated

14 years ago
Depends on: 30376

Comment 25

14 years ago
Bug 30376 is about the HTML -> TXT conversion used mainly in Mailnews. It's not
used at all when you view an HTML doc in the browser.
No longer depends on: 30376
(Assignee)

Updated

14 years ago
Depends on: 959, 28657, 81481
(Assignee)

Updated

14 years ago
Depends on: 210826

Updated

14 years ago
OS: Windows NT → All
Hardware: PC → All
Summary: [META] Fails test cases in Robin's HTML 4.0 Conformance Test → Fails test cases in Robin's HTML 4.0 Conformance Test
(Assignee)

Updated

14 years ago
Depends on: 204401
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Depends on: 277738
QA Contact: moied → chofmann
I think this bug has outlived its usefulness.
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.