Closed Bug 1458954 Opened 4 years ago Closed 4 years ago

moz.configure should catch CXX=clang and complain

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1451396

People

(Reporter: froydnj, Unassigned)

References

Details

mw came to #build today with a link error about not finding __cxa_guard_acquire and other similar C++ runtime bits.  After an embarrassingly long time, we figured out that he had CXX=clang, and clang as a linker driver won't automatically pull in the C++ libraries.  clang++ will, of course.

We should be able to figure this out much much earlier in configure and tell people about it.

We apparently did this once already in bug 933047, but that code no longer exists in build/autoconf/compiler-opts.m4, thanks to bug 1289239.  Bug 1289239 removed the check, as moz.configure will already check whether the C++ compiler is able to compile C++.  But the check is not strong enough to determine that it can actually link non-trivial C++ programs.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1451396
You need to log in before you can comment on or make changes to this bug.