Fix selectors for tabbrowser to use -moz-default-background-color as its default background in high contrast mode

VERIFIED FIXED in Firefox -esr60

Status

()

P1
normal
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: dao, Assigned: dao)

Tracking

({access, regression})

Trunk
Firefox 61
All
Windows
access, regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 60+, firefox-esr52 unaffected, firefox-esr60 verified, firefox59 unaffected, firefox60 verified, firefox61 verified)

Details

Attachments

(1 attachment)

Comment hidden (empty)

Comment 2

11 months ago
mozreview-review
Comment on attachment 8972945 [details]
Bug 1458956 - Fix selectors for tabbrowser to use -moz-default-background-color as its default background in high contrast mode.

https://reviewboard.mozilla.org/r/241510/#review247346

Thanks for splitting this out!
Attachment #8972945 - Flags: review?(mconley) → review+

Comment 3

11 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b7efdfb3decd
Fix selectors for tabbrowser to use -moz-default-background-color as its default background in high contrast mode. r=mconley
(Assignee)

Updated

11 months ago
Blocks: 1419152
(Assignee)

Comment 4

11 months ago
Comment on attachment 8972945 [details]
Bug 1458956 - Fix selectors for tabbrowser to use -moz-default-background-color as its default background in high contrast mode.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1442651
[User impact if declined]: We're regressing bug 1419152. That's an a11y regression.
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: see bug 1419152 comment 0
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: trivial fix for CSS selector
[String changes made/needed]: /
Attachment #8972945 - Flags: approval-mozilla-beta?

Comment 5

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b7efdfb3decd
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
status-firefox61: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 61
Comment on attachment 8972945 [details]
Bug 1458956 - Fix selectors for tabbrowser to use -moz-default-background-color as its default background in high contrast mode.

60 is on release now.
Attachment #8972945 - Flags: approval-mozilla-release?
Attachment #8972945 - Flags: approval-mozilla-esr60?
Attachment #8972945 - Flags: approval-mozilla-beta?
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → affected
I have reproduced this issue following steps from bug 1419152 comment 0, using Firefox  59.0a1 (2017.11.20) on Win 10 x64.
I did exploratory testing around opening new tabs with High Contrast Black settings on Windows 10 x64 and Win 7 x64 using Firefox 61.0b3, I didn't found any issues. 
Note: When change the system settings and in meantime Firefox is open, have to restart Firefox to apply the settings.
status-firefox61: fixed → verified
Flags: qe-verify+
Status: RESOLVED → VERIFIED
Comment on attachment 8972945 [details]
Bug 1458956 - Fix selectors for tabbrowser to use -moz-default-background-color as its default background in high contrast mode.

a11y regression with simple css fix, approved for 60.0.1
Attachment #8972945 - Flags: approval-mozilla-release?
Attachment #8972945 - Flags: approval-mozilla-release+
Attachment #8972945 - Flags: approval-mozilla-esr60?
Attachment #8972945 - Flags: approval-mozilla-esr60+

Comment 9

11 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-release/rev/b7e489ec7f45
status-firefox60: affected → fixed

Comment 10

11 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr60/rev/d5595a55f4c1
status-firefox-esr60: affected → fixed
(Assignee)

Updated

10 months ago
Duplicate of this bug: 1436027
Added this to Firefox and ESR 60.0.1 release notes
relnote-firefox: --- → 60+
I can confirm this issue is fixed, I verified using Firefox 60.0.1 and 60.0.1esr, on Windows 10 x64, Windows 7 x64 and Windows 8.1 x64.
status-firefox60: fixed → verified
status-firefox-esr60: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.