Closed Bug 1440865 Opened 2 years ago Closed 2 years ago

white screen despite high contrast black when switching to a tab that has to be re-rerendered

Categories

(Firefox :: Tabbed Browser, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 62
Tracking Status
firefox61 --- verified
firefox62 --- verified

People

(Reporter: joshudson, Assigned: dao)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180205100240

Steps to reproduce:

Turned on High Contrast Black

Opened a webpage that takes a long time to load

Opened another tab

Left it open for a few hours

Switched back to the original tab

I thought this was part of #1419152 but it isn't.

Reproduced OSes: Windows x86 (latest release), Linux Debian x64 (trunk)


Actual results:

screen turned almost solid white for several seconds. I'm pretty sure there's a spinner in the center. Please note this has happened on enough websites to rule out js code on the website causing it


Expected results:

screen should be black until re-render finished
Is this another regression from bug 1379587? A duplicate of one of those other bugs (see "See Also")?
Flags: needinfo?(florian)
(In reply to Dão Gottwald [::dao] from comment #1)
> Is this another regression from bug 1379587?

I don't think so, it sounds to me like it's the tab switch spinner that would need to be adapted to high contrast/dark themes. Mike, does this seem right?
Flags: needinfo?(florian) → needinfo?(mconley)
(In reply to Florian Quèze [:florian] from comment #2)
> I don't think so, it sounds to me like it's the tab switch spinner that
> would need to be adapted to high contrast/dark themes. Mike, does this seem
> right?

Yes, this sounds right. I suspect the colour that Joshua was seeing was this one: https://searchfox.org/mozilla-central/rev/78dbe34925f04975f16cb9a5d4938be714d41897/browser/base/content/tabbrowser.css#96
Flags: needinfo?(mconley)
Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P3
Comment on attachment 8972828 [details]
Bug 1440865 - Stop overriding tabbrowser-tabpanels' background for [pendingpaint].

https://reviewboard.mozilla.org/r/241396/#review247318

This is a great idea, and we should totally do this - except that the spinner seems to have the background colour hard-coded behind it, so things look a bit odd, for example, in private browsing windows:

https://imgur.com/a/FRVJiee

I wonder if we should swap out the spinner with an APNG with a transparent background or something.
Attachment #8972828 - Flags: review?(mconley) → review-
Depends on: 1458956
(In reply to Mike Conley (:mconley) (:⚙️) (Totally backlogged on reviews and needinfos) from comment #7)
> Comment on attachment 8972828 [details]
> Bug 1440865 - Stop adjusting tabbrowser-tabpanels' background for
> [pendingpaint] and use -moz-default-background-color for high contrast
> themes.
> 
> https://reviewboard.mozilla.org/r/241396/#review247318
> 
> This is a great idea, and we should totally do this - except that the
> spinner seems to have the background colour hard-coded behind it, so things
> look a bit odd, for example, in private browsing windows:
> 
> https://imgur.com/a/FRVJiee
> 
> I wonder if we should swap out the spinner with an APNG with a transparent
> background or something.

Stephen, could you provide us with such an image? The file in question is pendingpaint.png.
Flags: needinfo?(shorlander)
Blocks: 1459504
Attached image pendingpaint.png
This should work on different colored backgrounds.
Flags: needinfo?(shorlander)
Comment on attachment 8972828 [details]
Bug 1440865 - Stop overriding tabbrowser-tabpanels' background for [pendingpaint].

https://reviewboard.mozilla.org/r/241396/#review250086

Yeah, this looks great! Thanks!
Attachment #8972828 - Flags: review?(mconley) → review+
Flags: qe-verify+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4e1b874e708b
Stop overriding tabbrowser-tabpanels' background for [pendingpaint]. r=mconley
https://hg.mozilla.org/mozilla-central/rev/4e1b874e708b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Comment on attachment 8972828 [details]
Bug 1440865 - Stop overriding tabbrowser-tabpanels' background for [pendingpaint].

Approval Request Comment
[Feature/Bug causing the regression]: not a recent regression
[User impact if declined]: jarring experience when switching tabs and using a dark high contrast theme
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0
[List of other uplifts needed for the feature/fix]: /
[Is the change risky?]: no
[Why is the change risky/not risky?]: simple CSS fix
[String changes made/needed]: /
Attachment #8972828 - Flags: approval-mozilla-beta?
Comment on attachment 8972828 [details]
Bug 1440865 - Stop overriding tabbrowser-tabpanels' background for [pendingpaint].

Simple fix for users with dark high contrast themes. Approved for 61.0b6.
Attachment #8972828 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
I've reproduced the comment 0 issue on 61.0a1 20180421220102 and 
verified it as fixed on Windows8.1 x64 and Windows 10x64 for: 
61.0b5   2018-05-14
62.0a1   2018-05-16

Linux related, I'm not sure how this issue applies, since as default the high contrast background is white. (Ubuntu 16.04 & Debian 9.3). I wonder if I should use a custom black theme to test this fix? 
Joshua, do you use a custom black theme on Debian?
Flags: needinfo?(joshudson)
That would be correct more or less correct. I use a stock dark theme on Debian.

joshua@novaϟ env
[snip]
LANG=en_US.UTF-8
MOZ_ALLOW_GTK_DARK_THEME=true
QT_LINUX_ACCESSIBILITY_ALWAYS_ON=1
GTK_THEME=Adwaita:dark
_=/usr/bin/env
joshua@novaϟ
Flags: needinfo?(joshudson)
Joshua, would you be willing to help verifying this issue and thus confirming that this issue is fixed for high contrast Debian?
Flags: needinfo?(joshudson)
Hey; I just installed the latest nightly to test it but it will be some time before I can be certain it's fixed. I never got a reliable reproduction so making sure it is dead is hard.
Status: RESOLVED → VERIFIED
And I think I clicked the wrong button.
Flags: needinfo?(joshudson)
I'll mark this issue as verified based on comment 17, since only on Debian we still have to fully confirm this issue as fixed and I reckon if the case be we could open a new issue to track linux.
I have now actually confirmed the fix on Firefox Nightly. (I managed to get a tab to hang due to a spotty DNS server making confirmation obvious.)
I reckon no action is required now for this issue. Thanks a lot Joshua for involvement and help.
You need to log in before you can comment on or make changes to this bug.