Closed Bug 1459057 Opened 4 years ago Closed 2 years ago

.xslt loaded over FTP not treated as XSLT

Categories

(Core :: Networking: FTP, defect, P5)

61 Branch
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox60 --- affected
firefox61 --- affected
firefox62 --- affected

People

(Reporter: felix.bau, Unassigned)

Details

(Whiteboard: [necko-triaged])

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180503100146

Steps to reproduce:

I opened ftp://ftp.fu-berlin.de/doc/rfc/authors/rfc2629.xslt (without view-source: at first)


Actual results:

Firefox tries to render the stylesheet for some reason (probably because it contains HTML and CSS, since it's some kind of template at least to my understanding).

The screenshot that shows what I mean is called "render"


Expected results:

It should have either showed the source code like it does for css files already:
https://www.heise.de/assets/heise/heise/css/heise.css?f984f0c54d2f7787bd7b

Or used the xml view, like it did for another xsl file on the internet that I downloaded. (renaming that example file to xslt didn't change the outcome though)
The screenshot that shows how this looks like is "another xsl(t) file that works fine".


When I download ftp://ftp.fu-berlin.de/doc/rfc/authors/rfc2629.xslt and open it then, I just get a syntax error instead (not well defined xml)
The corresponding screenshot is called "syntax error"
Attached image syntax error
Attached image render
I can confirm that opening the link in description (ftp://ftp.fu-berlin.de/doc/rfc/authors/rfc2629.xslt) will attempt to render the page on all Mozilla builds tested (Old release v49.0.2, latest release v59.0.3, beta v60.0, nightly v62.0a1) and an alert pop-up get displayed with text: "550 /doc/rfc/authors/{@src}:No such file or directory".
The Chrome browser with try to render the page as well, while EDGE and IE11, will display the code.
Status: UNCONFIRMED → NEW
Component: Untriaged → XSLT
Ever confirmed: true
Product: Firefox → Core
It appears that the FTP code doesn't map .xslt to application/xslt+xml and it gets parsed as text/html.
Component: XSLT → Networking: FTP
Summary: Firefox tries to render xsl(t) stylesheets instead of displaying their source code → .xslt loaded over FTP not treated as XSLT
Priority: -- → P5
Whiteboard: [necko-triaged]

(Djfe from comment #0)

ftp://ftp.fu-berlin.de/doc/rfc/authors/rfc2629.xslt

As per bug 1560699, ftp:// resources will be treated as application/octet-stream.

https://www.zedat.fu-berlin.de/FTP
The university's IT department thanked for my email notification. They consider offering https as well, but it would take some time for 'complexity' reasons.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.