Location in New Bookmark dialog should be encoded

RESOLVED WORKSFORME

Status

()

Core
Internationalization
RESOLVED WORKSFORME
16 years ago
8 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Jungshik Shin)

Tracking

(Blocks: 1 bug, {intl})

Trunk
mozilla1.0.1
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Non-ASCII string entered in Location field in New Bookmark
dialog should be encoded, as URL bar.

Steps to reproduce:
(1) Open Manage Bookmark dialog.
(2) Select [File]-[New]-[Bookmark].
(3) Enter an URL which contains non-ASCII string in Location field.

Actual result: The non-ASCII string becomes garbage.

Expected result: The non-ASCII string becomes encoded string.


Original report in Bugzilla-jp:
http://bugzilla.mozilla.gr.jp/show_bug.cgi?id=2221

Comment 1

16 years ago
-> tao
Assignee: ben → tao

Comment 2

16 years ago
It seems to me the input data got clobbered before making it to the display.
Assignee: tao → yokoyama
Component: Bookmarks → Internationalization
QA Contact: claudius → ruixu

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0.1

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → kasumi

Comment 3

16 years ago
Many bugs regarding non-ascii for path are reported.
bug 107448, 117754, 139625, 125621, 125640.

Comment 4

16 years ago
Many bugs regarding non-ascii for path are reported.
bug 107448, bug 117754, bug 139625, bug 125621, bug 125640.
Blocks: 271398

Comment 5

13 years ago
I think both roy and me are off mozilla for more than 2 years. If these bugs are
still here now, I think the real stauts is 'won't fix'. If you want to reopen
it, please find a new owner for it first. 
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 6

13 years ago
Mass Reassign Please excuse the spam
Assignee: tetsuroy → nobody

Comment 7

13 years ago
Mass Re-opening Bugs Frank Tang Closed on Wensday March 02 for no reason, all
the spam is his fault feel free to tar and feather him
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 8

13 years ago
Reassigning Franks old bugs to Jungshik Shin for triage - Sorry for spam
Assignee: nobody → jshin1987
Status: REOPENED → NEW

Comment 9

12 years ago
WFM with Firefox/2005122505-trunk/WinXP, SeaMonkey/2005122508-trunk/WinXP.
QA Contact: kasumi → i18n

Comment 10

8 years ago
Cannot reproduce with SeaMonkey/20100130-trunk/WinXP

-> WORKSFORME
Status: NEW → RESOLVED
Last Resolved: 13 years ago8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.