Allow to build both GLX and EGL OpenGL backends for X11/Wayland builds

RESOLVED FIXED in Firefox 62

Status

()

enhancement
P2
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: stransky, Assigned: stransky)

Tracking

(Blocks 1 bug)

Trunk
mozilla62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Assignee)

Description

a year ago
This is a follow up from Bug 788319 comment 47

In order to make Wayland builds usable, implement run-time GL context switch to use GLX on X11 and EGL on Wayland.
(Assignee)

Updated

a year ago
Summary: Allow to build both GLX and EGL OpenGL backends for X11&Wayland builds → Allow to build both GLX and EGL OpenGL backends for X11/Wayland builds
(Assignee)

Comment 1

a year ago
Posted patch WIP patch (obsolete) — Splinter Review
Jeff, what do you think about this approach? It will leave X11/GLX backend as is and we can fix/update EGL for Wayland backend only.
Attachment #8974378 - Flags: feedback?(jgilbert)
(Assignee)

Updated

a year ago
Blocks: wayland
(Assignee)

Updated

a year ago
Assignee: nobody → stransky
(Assignee)

Updated

a year ago
Blocks: 1438144
(Assignee)

Updated

11 months ago
Priority: -- → P2
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Updated

11 months ago
Attachment #8974378 - Attachment is obsolete: true
Attachment #8974378 - Flags: feedback?(jgilbert)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Attachment #8975816 - Flags: review?(jmuizelaar) → review?(jgilbert)
Attachment #8975817 - Flags: review?(jmuizelaar) → review?(jgilbert)
Attachment #8975818 - Flags: review?(jmuizelaar) → review?(jgilbert)
(Assignee)

Updated

11 months ago
Depends on: 1464037
(Assignee)

Updated

11 months ago
Attachment #8975818 - Attachment is obsolete: true
Attachment #8975818 - Flags: review?(jgilbert)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
(Assignee)

Comment 10

11 months ago
This is the last missing piece to build Wayland enabled builds on Linux/Gtk.

Comment 11

11 months ago
mozreview-review
Comment on attachment 8975816 [details]
Bug 1460255 - Implement GLContextProviderWayland,

https://reviewboard.mozilla.org/r/244010/#review253364
Attachment #8975816 - Flags: review?(lsalzman) → review+

Comment 12

11 months ago
mozreview-review
Comment on attachment 8975817 [details]
Bug 1460255 - Use GLContextProviderWayland GL provider on Wayland enabled builds,

https://reviewboard.mozilla.org/r/244012/#review253366
Attachment #8975817 - Flags: review?(lsalzman) → review+

Comment 13

11 months ago
(In reply to Martin Stránský [:stransky] from comment #10)
> This is the last missing piece to build Wayland enabled builds on Linux/Gtk.

since it's reviewed, can it be pushed?
(Assignee)

Comment 14

11 months ago
(In reply to David Heidelberg from comment #13)
> (In reply to Martin Stránský [:stransky] from comment #10)
> > This is the last missing piece to build Wayland enabled builds on Linux/Gtk.
> 
> since it's reviewed, can it be pushed?

Please wait until try finishes:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=3f75e43ecb659cbafbeb2332f46eda0085fea971
(Assignee)

Updated

11 months ago
Duplicate of this bug: 1464994

Comment 16

11 months ago
Pushed by stransky@redhat.com:
https://hg.mozilla.org/integration/autoland/rev/446eb68ac1c3
Implement GLContextProviderWayland, r=lsalzman
https://hg.mozilla.org/integration/autoland/rev/229a64156f70
Use GLContextProviderWayland GL provider on Wayland enabled builds, r=lsalzman

Comment 17

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/446eb68ac1c3
https://hg.mozilla.org/mozilla-central/rev/229a64156f70
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
You need to log in before you can comment on or make changes to this bug.