Closed Bug 1464994 Opened 2 years ago Closed 2 years ago

build failure (Unified_cpp_gfx_gl0.o relocation R_X86_64_PC32) in gfx with --enable-default-toolkit=cairo-gtk3-wayland

Categories

(Core :: Graphics, defect)

Unspecified
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1460255

People

(Reporter: cosmo0920, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20180509233012

Steps to reproduce:

Checkout gecko-dev source tree:

revision is:
---
commit 2f9a3d61e9ed9056f817cab7b64cfff390800811
Merge: 3ead0a41631c 4d05f461aa3c
Author: Ciure Andrei <aciure@mozilla.com>
Date:   Tue May 29 00:53:52 2018 +0300

    Merge inbound to mozilla-central. a=merge
---

Build with the following configuration:

---
. $topsrcdir/browser/config/mozconfig

ac_add_options --enable-default-toolkit=cairo-gtk3-wayland

mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir
mk_add_options AUTOCLOBBER=1

ac_add_options --disable-crashreporter
ac_add_options --without-system-nspr
ac_add_options --without-system-nss

ac_add_options --enable-debug
ac_add_options --disable-optimize

ac_add_options --enable-release
ac_add_options --disable-tests
---

and then,

---
$ ./mach build
---


Actual results:

Build failed.

---
 4:10.29 libxul.so
 5:06.91 ../../gfx/gl/Unified_cpp_gfx_gl0.o: In function `mozilla::gl::GLScreenBuffer::CreateFactory(mozilla::gl::GLContext*, mozilla::gl::SurfaceCaps const&, mozilla::layers::KnowsCompositor*, mozilla::layers::TextureFlags const&)':
 5:06.91 /home/hhatake/GitHub/gecko-dev/gfx/gl/GLScreenBuffer.cpp:87: undefined reference to `mozilla::gl::sGLXLibrary'
 5:06.91 /usr/bin/ld: ../../gfx/gl/Unified_cpp_gfx_gl0.o: relocation R_X86_64_PC32 against undefined hidden symbol `_ZN7mozilla2gl11sGLXLibraryE' can not be used when making a shared object
 5:06.91 /usr/bin/ld: final link failed: Bad value
 5:06.91 collect2: error: ld returned 1 exit status
 5:06.91 /home/hhatake/GitHub/gecko-dev/config/rules.mk:679: recipe for target 'libxul.so' failed
 5:06.91 make[4]: *** [libxul.so] Error 1
 5:06.91 /home/hhatake/GitHub/gecko-dev/config/recurse.mk:73: recipe for target 'toolkit/library/target' failed
 5:06.91 make[3]: *** [toolkit/library/target] Error 2
 5:06.91 /home/hhatake/GitHub/gecko-dev/config/recurse.mk:32: recipe for target 'compile' failed
 5:06.91 make[2]: *** [compile] Error 2
 5:06.91 /home/hhatake/GitHub/gecko-dev/config/rules.mk:418: recipe for target 'default' failed
 5:06.91 make[1]: *** [default] Error 2
 5:06.91 client.mk:150: recipe for target 'build' failed
 5:06.91 make: *** [build] Error 2
 5:06.96 48 compiler warnings present.
 5:06.99 /usr/bin/notify-send --app-name=Mozilla Build System Mozilla Build System Build failed
---


Expected results:

Can build with --enable-default-toolkit=cairo-gtk3-wayland.
Blocks: wayland
Component: Untriaged → Graphics
OS: Unspecified → Linux
Product: Firefox → Core
Attached file config.log
Attached file config.status
It's dupe of Bug 1460255 which should fix that.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1460255
You need to log in before you can comment on or make changes to this bug.