Closed Bug 1460273 Opened 4 years ago Closed 4 years ago

caret position after backspace in contenteditable = true

Categories

(Core :: DOM: Editor, defect)

59 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1453872

People

(Reporter: reloecc, Unassigned)

References

()

Details

(Keywords: testcase)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.30 Safari/537.36

Steps to reproduce:

1) Place caret before the "This" on the third line of the editable div in:
http://fiddle.tinymce.com/wpgaab/2

2) press backspace > home > backspace

version:  Firefox 59.0.2 (64-bit)


Actual results:

Caret is placed in the middle of text insted of the end of the former first line.


Expected results:

Caret should be placed right before the "This" word.
https://hg.mozilla.org/integration/autoland/json-pushes?changeset=bc6e8d505359dcfb67af363b572502070f13714b&full=1

Thank you for the report. For future reference, it would be appreciated if you could first test the latest Nightly in a brand new profile.
https://nightly.mozilla.org
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles
https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines

(In reply to reloecc from comment #0)
> 1) Place caret before the "This" on the third line of the editable div in:
> http://fiddle.tinymce.com/wpgaab/2
> 
> 2) press backspace

That's sufficient to reproduce the issue.
Status: UNCONFIRMED → RESOLVED
Has STR: --- → yes
Closed: 4 years ago
Component: Untriaged → Editor
Keywords: testcase
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 1453872
You need to log in before you can comment on or make changes to this bug.