Closed Bug 1461539 Opened 6 years ago Closed 6 years ago

[XFCE] window not maximized after fullscreen video

Categories

(Core :: Widget: Gtk, defect)

60 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: munircontractor, Unassigned)

References

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180509091545

Steps to reproduce:

Using Firefox 60.0 on Archlinux with XFCE desktop

1. Opened Firefox with window maximized.
2. Removed title bar from the browser window. (Open Firefox, went to preferences -> customize, unchecked the title bar checkbox at the bottom)
3. Opened a website with video on it (youtube) and clicked fullscreen mode for the video player.
4. When exiting from fullscreen mode, Firefox window is no longer maximized.


Actual results:

Firefox window was no longer maximized after exiting fullscreen mode for video even though it was maximized before going to fullscreen mode. 

This happened only after unchecking the remove title bar button in customize menu. If the title bar is added back, the window stays maximized after exiting fullscreen mode.

The behaviour is seen on multiple websites include youtube, streamable and reddit.


Expected results:

The browser window should stay maximized after exiting fullscreen mode with or without the title bar.
Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID:20180516032328

I cannot reproduce the issue on Ubuntu 16.04 x64 using Release 60.0.1 with the STR from description. However, I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Component: Untriaged → Toolbars and Customization
Same for me. Also running Firefox 60.0.1 on Archlinux with XFCE. After leaving video fullscreen Firefox is not maximized anymore and has the same gap size on all 4 window borders.
Can you please try to reproduce this with mozregression[1]? That will help us by testing with a clean profile as well as finding when this stopped working correctly. 

[1] http://mozilla.github.io/mozregression/
Flags: needinfo?(munircontractor)
alright, behavior is starting with following build:

app_name: firefox
build_date: 2018-01-18
build_file: /home/phil/.mozilla/mozregression/persist/2018-01-18--mozilla-central--firefox-59.0a1.en-US.linux-x86_64.tar.bz2
build_type: nightly
build_url: https://archive.mozilla.org/pub/firefox/nightly/2018/01/2018-01-18-22-01-48-mozilla-central/firefox-59.0a1.en-US.linux-x86_64.tar.bz2
changeset: d4d53f4069f43eab1aae8bcf4def08bdb5a84d8d
pushlog_url: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e157471df46e457a0f9c1eb785dc8cb5746067a4&tochange=d4d53f4069f43eab1aae8bcf4def08bdb5a84d8d
repo_name: mozilla-central
repo_url: https://hg.mozilla.org/mozilla-central

build from 2018-01-14 is ok (firefox window still maximized after leaving video fullscreen)
BUT hiding the titlebar is not working under XFCE. 

So i guess adding proper "hide titlebar" support created the bug. some users on reddit told me
that gnome seems not be affected. probably it has to do with migration from GTK2 to GTK3?
XFCE4 has still some GTK2 dependencies. 
With build from 2018-01-18 firefox doesnt make use of xfce theme anymore after disabling the titlebar.
Blocks: 1417933
Component: Toolbars and Customization → Widget: Gtk
Flags: needinfo?(munircontractor) → needinfo?(stransky)
Product: Firefox → Core
Hi, I don't think this is a Firefox-specific issue. All GTK3 apps using csd have this behaviour under Xfce. It is a bug in which client side shadows cause problems with tiling and remembering maximization. You can work around it by disabling csd shadows.
See here for how to do that: https://mail.xfce.org/pipermail/xfce/2016-June/035068.html
This is not a regression but a bug in the new feature. It works fine in default setup (Titlebar enabled). According to comment 5 it's xfce specific issue.
Flags: needinfo?(stransky)
Keywords: regression
Summary: window not maximized after fullscreen video → [XFCE] window not maximized after fullscreen video
using the gtk3 css settings from the link of comment 5, firefox has no gap anymore after leaving fullscreen video, but still loses its maximized state. (not maximized anymore but filling the whole screen)
also notable is if firefox is not maximized the first tab is positioned a bit more right ... https://imgur.com/a/vZqpnVn
(In reply to Philipp N from comment #7)
> also notable is if firefox is not maximized the first tab is positioned a
> bit more right ... https://imgur.com/a/vZqpnVn

Yes, this is by design to provide an area that can be used to drag the window.
(In reply to munircontractor from comment #0)

Both version 4.12.5 and 4.13.1 of xfwm4 now include patch from 
https://bugzilla.xfce.org/show_bug.cgi?id=14514.
Although description doesn't say anything about Firefox specifically, it's
related to full-screen transitions. After updating xfwm4 to version 4.12.5
I can no longer see the bug, while downgrading to 4.12.4 brings it back.
Bisecting also points to https://git.xfce.org/xfce/xfwm4/commit?id=860b369474875442ff1e1b14589522a8db8e9804.

Could you test it again with xfwm4 4.12.5 or 4.13.1?
Flags: needinfo?(munircontractor)
(In reply to Rinat from comment #9)
> (In reply to munircontractor from comment #0)
> 
> Both version 4.12.5 and 4.13.1 of xfwm4 now include patch from 
> https://bugzilla.xfce.org/show_bug.cgi?id=14514.
> Although description doesn't say anything about Firefox specifically, it's
> related to full-screen transitions. After updating xfwm4 to version 4.12.5
> I can no longer see the bug, while downgrading to 4.12.4 brings it back.
> Bisecting also points to
> https://git.xfce.org/xfce/xfwm4/
> commit?id=860b369474875442ff1e1b14589522a8db8e9804.
> 
> Could you test it again with xfwm4 4.12.5 or 4.13.1?

Yup, behaviour is as expected now with xfwm4 4.12.5. The browser 
window stays maximized. So I guess it was an xfce issue. Thanks.
Flags: needinfo?(munircontractor)
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID

This occurs on XFCE 4.14

(In reply to ericcheng986 from comment #12)

This occurs on XFCE 4.14

Hmm, seems to have suddenly resolved itself

You need to log in before you can comment on or make changes to this bug.