Ability to reference users by their real names

RESOLVED FIXED in Bugzilla 2.18

Status

()

Bugzilla
Creating/Changing Bugs
P3
enhancement
RESOLVED FIXED
16 years ago
5 years ago

People

(Reporter: Toms Baugis, Assigned: Toms Baugis)

Tracking

2.15
Bugzilla 2.18
Other
All
Dependency tree / graph

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

16 years ago
It is very convinient for small bugzillas to reference users in CC, assigned to
and similar fields just by their real names. Together with option to display
realnames in buglist, it is a big advancement of UI
(Assignee)

Comment 1

16 years ago
Created attachment 84623 [details] [diff] [review]
V1

Patch to enable user referencing by realname. To make it work you have to
change value of parameter assignbyrealname to on.
In this patch is also included feature to show realnames in buglist
(Assignee)

Updated

16 years ago
Keywords: patch, review
(Assignee)

Comment 2

16 years ago
Created attachment 84626 [details] [diff] [review]
V2

Sorry, real stupid windows stuff was left in the code.
Attachment #84623 - Attachment is obsolete: true
(Assignee)

Comment 3

16 years ago
Created attachment 85256 [details] [diff] [review]
V2.1

Fixed small bug - realname was set to blank when changing password. 
Also - removed bash lines, which where modified for win installation.
Attachment #84626 - Attachment is obsolete: true
(Assignee)

Comment 4

16 years ago
Created attachment 85595 [details] [diff] [review]
v2.2

When entering bug and referencing users by their real names, mail was sent
twice. FIXED
Attachment #85256 - Attachment is obsolete: true
Priority: -- → P3
Target Milestone: --- → Bugzilla 2.18
(Assignee)

Comment 5

15 years ago
Created attachment 101677 [details] [diff] [review]
v2.3

When adding CC's mail was sent twice: FIXED
Also - diffed with bugzilla v2.16.1
Attachment #85595 - Attachment is obsolete: true
(Assignee)

Comment 6

15 years ago
unfortunately nobody told me that something like this is being developed :/

*** This bug has been marked as a duplicate of 162990 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
the summary on the other bug doesn't mention this, although apparently that
patch did fix it.  Will re-resolve shortly
Blocks: 173124
Status: RESOLVED → REOPENED
Depends on: 162990
Resolution: DUPLICATE → ---
fixed by the checkin from bug 162990
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.