1.14ms uninterruptible reflow at draw/<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:13:742

RESOLVED DUPLICATE of bug 1357487

Status

defect
RESOLVED DUPLICATE of bug 1357487
Last year
4 months ago

People

(Reporter: geeknik, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(firefox62 affected)

Details

(Whiteboard: [ohnoreflow][qf-][fxperf])

Here's the stack:

draw/<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:13:742
[26]</e.exports/o.each@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:12:5045
draw@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:13:336
draw/<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:27690
[26]</e.exports/o.each@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:12:5045
draw@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:27663
render@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:27363
[26]</e.exports/o.callback@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:12:16862
advance@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:20062
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19777
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
FrameRequestCallback*requestAnimationFrame@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19576
startDigest@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19868
requestAnimationFrame/t.request<@moz-extension://2a497ae9-5020-43f3-b1bb-83008feef0c6/lib/Chart.min.js:11:19633
Whiteboard: [ohnoreflow][qf][photon-performance] → [ohnoreflow][qf][fxperf]
Whiteboard: [ohnoreflow][qf][fxperf] → [ohnoreflow][qf-][fxperf]
Out of curiosity, which add-on is this, geeknik? If you go to about:debugging, which one has an internal UUID of 2a497ae9-5020-43f3-b1bb-83008feef0c6 ?
Component: Untriaged → Add-ons
Product: Firefox → Tech Evangelism
Reporter

Comment 2

Last year
Hi Mike, sorry for the delay, the extension is called Crypto Tab: https://addons.mozilla.org/en-US/firefox/addon/crypto-tab/
While it might be possible for the add-on to be modified to avoid the layout flush, I think the better (and more complete) solution is to ensure that add-ons that are causing layout flushes in their moz-extension pages can't jank the browser UI. I believe moving those pages to their own process (which is what we do on Windows and macOS) is the best solution here, so I'm going to dupe this over to bug 1357487.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1357487
Component: Add-ons → General
Product: Tech Evangelism → WebExtensions
You need to log in before you can comment on or make changes to this bug.