Closed Bug 1462534 Opened 2 years ago Closed 2 years ago

ESR52 build problems - emevoucher signing, missing logs on treeherder

Categories

(Release Engineering :: General, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: nthomas, Unassigned)

References

Details

Attachments

(1 file)

Something odd is happening on ESR52 and might be fallout from various python upgrades. The current tip is at https://hg.mozilla.org/releases/mozilla-esr52/rev/b71294fa76350589b14335982dddde96a85d138f. The mac & windows compile jobs are failing, and treeherder doesn't get the logs.

Missing logs:
I think they're still being uploaded, eg https://archive.mozilla.org/pub/firefox/tinderbox-builds/mozilla-esr52-macosx64/1526605972/mozilla-esr52-macosx64-bm86-build1-build1.txt.gz, but something goes wrong with getting the message to Treeherder. Maybe pulse ?

Signing:
End of the log goes like
18:55:34     INFO -  Usage: signtool.py [options] file [file ...]
18:55:34     INFO -  If no include patterns are specified, all files will be considered. -i/-x only
18:55:34     INFO -  have effect when signing entire directories.
18:55:34     INFO -  signtool.py: error: invalid format: emevoucher
which is weird, because we still support emevoucher based on search hits in tools and puppet.  See also bug 1381719 about disabling EME vouchers on ESR52.

Maybe related - Bug 1462429 contains some buildbot scheduler weirdness from about 06:40 Pacific on the 17th.

Any ideas on this Ben ?
Flags: needinfo?(bhearsum)
re the logs, I see a lot of mess in my browser console about
  TypeError: "({title:"Buildername"}) is not a function"
and logs don't seem to work a week ago either.
(In reply to Nick Thomas [:nthomas] (UTC+12) from comment #0)
> Signing:
> End of the log goes like
> 18:55:34     INFO -  Usage: signtool.py [options] file [file ...]
> 18:55:34     INFO -  If no include patterns are specified, all files will be
> considered. -i/-x only
> 18:55:34     INFO -  have effect when signing entire directories.
> 18:55:34     INFO -  signtool.py: error: invalid format: emevoucher
> which is weird, because we still support emevoucher based on search hits in
> tools and puppet.  See also bug 1381719 about disabling EME vouchers on
> ESR52.

It looks like this is caused by a missing comma in https://hg.mozilla.org/build/tools/rev/366c73410d4e#l3.14 actually, wheh!
Flags: needinfo?(bhearsum)
Attachment #8976942 - Flags: review?(jlorenzo)
Comment on attachment 8976942 [details] [diff] [review]
fix allowed formats in signtool.py

Review of attachment 8976942 [details] [diff] [review]:
-----------------------------------------------------------------

That's a fallout of bug 1409091. Sorry about this. I thought my testing covered this. It turned out I forgot to test the "old" signtool, which is not used anymore in scriptworker. Thank you for the investigation, guys!
Attachment #8976942 - Flags: review?(jlorenzo) → review+
Depends on: 1409091
(In reply to Nick Thomas [:nthomas] (UTC+12) from comment #1)
> re the logs, I see a lot of mess in my browser console about
>   TypeError: "({title:"Buildername"}) is not a function"
> and logs don't seem to work a week ago either.

I spoke with the Treeherder folks, it looks like this a regression on their side: https://bugzilla.mozilla.org/show_bug.cgi?id=1462625
My triggered job worked, looks like we're good here!
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.