Closed Bug 1462935 Opened 3 years ago Closed 3 years ago

Installer does not include dark theme when upgrading

Categories

(Thunderbird :: Theme, defect)

defect
Not set
normal

Tracking

(thunderbird_esr60 fixed, thunderbird60 fixed)

RESOLVED FIXED
Thunderbird 60.0
Tracking Status
thunderbird_esr60 --- fixed
thunderbird60 --- fixed

People

(Reporter: josh.dix, Assigned: Paenglab)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180516032328

Steps to reproduce:

I installed Thunderbird 52.x, then decided I wanted to upgrade to 60.xb when I noticed there was a dark theme now included. I installed in the same directory as was the default action in windows 10 os. The dark theme was not available in the list of themes.


Actual results:

After installation of 60.xb, I could not be located the dark theme. I figured this was due to it being an upgrade instead of a full install. To 'prove' it was an install error I did a full uninstall of Thunderbird (using control panel) and reinstall (using the 60.xb exe again). This time the dark theme was listed and operational.


Expected results:

Dark theme should have been available.
Component: Untriaged → Theme
I tried it with a 52 profile and the dark theme was here. You wrote 60.xb. Please can you give us the correct version? The dark theme is only included starting with 60.b6.
I installed the 52.8.0 then upgraded to 60.b6 and only had Default and Light themes, no Dark was available.
Then I uninstalled thunderbird and deleted profiles and local folders (C:\Users\username\Appdata\...), after that I tried to installed 60.b6 directly still no Dark theme for me.

I'm using Windows 10 Pro (1803) and Thunderbird 60.b6 en-us
Summary: Installer does not include dark them when upgrading → Installer does not include dark theme when upgrading
(In reply to Richard Marti (:Paenglab) from comment #1)
> I tried it with a 52 profile and the dark theme was here. You wrote 60.xb.
> Please can you give us the correct version? The dark theme is only included
> starting with 60.b6.

Rich, I meant version 60.b6. I am not sure why I typed what I had.

Victor, Sorry to hear. I didn't even delete the profiles or app data, I just uninstalled and reinstalled.

My original version was from chocolatey (verified by logs) and this could have had something to do with it. It was thunderbird 52.8. I installed the 60.b6 manually, first as an update, then again after I removed it to allow for the reinstall.

Let me know if I can be of more help, thanks
This bug depends on "lightweightThemes.selectedThemeID" not being set.

STR:
0. Thunderbird 60b9, clean profile
1. Open Add-ons page
2. Select Themes

Expected:
3 Themes visible: Default, Light, Dark

Actual:
2 Themes visible: Default, Light

Reason:
LightweightThemeManager.jsm:194:
> if (_prefs.getCharPref("selectedThemeID") == theme.id) {
throws if the variable is not set. I have no idea how Thunderbird is tracking mozilla-central, but the issue is fixed there by https://hg.mozilla.org/releases/mozilla-release/rev/0819fc14fc57 – but that commit sounds huge.

Alternatively, it should be sufficient to alter the line to
> if (_prefs.getCharPref("selectedThemeID", "") == theme.id) {
Attached patch Bug1462935.patchSplinter Review
This is for TB 60 only because we have this line already in 61 and up since bug 1456225.

I played a bit and with the empty pref the the dark theme is shown.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8988591 - Flags: review?(jorgk)
Attachment #8988591 - Flags: approval-comm-esr60?
Comment on attachment 8988591 [details] [diff] [review]
Bug1462935.patch

OK, Sadly I'm currently managing two beta branches, so this needs uplift to the TB 60 beta branch.
Attachment #8988591 - Flags: review?(jorgk)
Attachment #8988591 - Flags: review+
Attachment #8988591 - Flags: approval-comm-esr60?
Attachment #8988591 - Flags: approval-comm-esr60+
Attachment #8988591 - Flags: approval-comm-beta+
TB 60 beta 10 (BETA_60_CONTINUATION branch):
https://hg.mozilla.org/releases/comm-beta/rev/b747667d404c580c615893d48ae90d6922c95f17
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 60.0
You need to log in before you can comment on or make changes to this bug.