Closed Bug 146321 Opened 22 years ago Closed 21 years ago

implement File Menu: Send Link

Categories

(Camino Graveyard :: Toolbars & Menus, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Camino0.7

People

(Reporter: winnie, Assigned: sfraser_bugs)

References

Details

Attachments

(1 file)

"File Menu: Send Link" should be greyed out if no current window is open.  Maybe
related to external protocol support (bug 145807).
Blocks: 145820
->sdagley
Assignee: saari → sdagley
Not related to external protocol support.  Should be handled by whatever
listener updates the state of the menu items when a window opens/closes/loads a
new page
Using Chimera/20020602, no "Send Link" item is visible in the File menu.
This was fixed long, long ago. I can't even remember the last build that had a
"Send Link" item.
Resolving Invalid since the menu item no longer apparently exists.
Status: NEW → RESOLVED
Closed: 22 years ago
Resolution: --- → INVALID
Reopening - this is a key requirement.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
So then this bug is actually about implementing Send Link, then, I take it.
I think it should be up to Pinkerton whether or not we're going to have this
menu item if that's what this bug is about now. I hardly think it is a key
requirement since you can do the exact same thing by typing cmd-L and choosing
Services>Mail>Mail Text.
Yes - the original desrciption does not make that clear.  The product should
implement the ability to launch the default mail app with the current URL
prepopulated in the message body.
Typing cmd-L and choosing Services>Mail>Mail Text does indeed accomplish the
same thing but it requires the user to select the URL before going to a menu
three levels deep.  

A top level menu item would make this capability more discoverable and easier to
use (one step rather than two).
Component: General → Toolbars & Menus
QA Contact: winnie → sairuh
Summary: File Menu: Send Link → implement File Menu: Send Link
i think effectively implementing Services could possibly eliminate adding this
menu item --see bug 152023 comment 6.
Setting to an RFE and asking what's the current opinion on whether or not we'd
actually want this as a top level menu item rather than a Services item?
Severity: normal → enhancement
It'd be almost like having a Chimera-specific variant of the Copy command,
except much less useful. The Mail service provides this functionality in a
system-wide fashion, through an operation that works the same in all apps that
support services.

And so what if it's not a top level menu command? Should it even be one? No.
Sending a link over e-mail is something that people don't want/need to do as
frequently as they open or close windows/tabs. Making the File menu longer with
an item whose functionality is already available and one that isn't actually all
that important in the first place seems a tad silly to me.
*** Bug 171724 has been marked as a duplicate of this bug. ***
i agree with lauri. i don't think this should be yet another toplevel menu item.
(context menus are another case --see bug 166958.) once services are
implemented, that should suffice.

recommend WONTFIX.
Services only work with Apple's Mail.app, and are unavailable if it is not on
the user's system, or if the user has never configured it.  Mail's services also
do not place the page title in the subject header, as do IE and Mozilla.  I
don't believe that services adequately provide this functionality.
Joseph, thanks for the patch

-> pinkerton for consideration
Assignee: sdagley → pinkerton
Status: REOPENED → NEW
Keywords: patch, review
Summary: implement File Menu: Send Link → implement File Menu: Send Link
i think this is probably worth considering. it does make sense to have something
like this.
->simon?

services has been implemented, but it turns out that sending the url (or page)
is not directly available from the services menu. instead, it'd take the user
two steps to accomplish this (select urlbar, the select mail under services).

as things stand now, i'm backing down from my comment 16 --having the File >
Send Link menu item would provide a good 1-step method to accomplish this task.
Assignee: pinkerton → sfraser
Blocks: 147975
Target Milestone: --- → Chimera0.7
Status: NEW → ASSIGNED
I checked in the patch, with some fixes. Thanks!
Status: ASSIGNED → RESOLVED
Closed: 22 years ago21 years ago
Resolution: --- → FIXED
Verified fixed in Chimera 2002111912.
Status: RESOLVED → VERIFIED
No longer blocks: 145820, 147975
You need to log in before you can comment on or make changes to this bug.