Open Bug 1463726 Opened Last year Updated 4 months ago

No activity stream

Categories

(Firefox :: New Tab Page, defect, P5)

61 Branch
defect

Tracking

()

UNCONFIRMED
Tracking Status
firefox63 --- wontfix
firefox64 --- wontfix

People

(Reporter: jsnjack, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:61.0) Gecko/20100101 Firefox/61.0
Build ID: 20180521110957

Steps to reproduce:

1. Open Firefox
2. Go to Preferences > Home
3. Check Firefox Home (Default)
4. Open a new tab


Actual results:

A new empty tab is opened without activity stream


Expected results:

A new empty tab is opened with activity stream
Has STR: --- → yes
Component: Untriaged → New Tab Page
Hello!

Is the cog shown on new tabs? If yes, this is a different bug and any further
info on this bug is appreciated. If it is just a white page, please follow
these steps:

1. On a new tab, open the "about:config" (without quotes) and press the
   "I accept the risk!" button.
2. The Configuration page is opened. Using the search box on the top of the
   page, search for the "browser.newtabpage.enabled" variable.
3. Double-click the value until the Value column shows "true".
4. Restart and check if the bug exists.

If it works, please check and give additional info to this bug:
Bug 1460963

and request someone to close this bug report. If it isn't, report it on this
bug and we will look at it.
Flags: needinfo?(jsnjack)
Hi Gacel,

Thank you for looking into it. I have browser.newtabpage.enabled set to true and browser.library.activity-stream.enabled set to true. I still see just a white page (the only one element on the page is Firefox logo in top left corner)
Flags: needinfo?(jsnjack)
Refreshing Firefox, as it was suggested in the linked ticket, resolved the issue
(In reply to Yauhen Shulitski from comment #3)
> Refreshing Firefox, as it was suggested in the linked ticket, resolved the
> issue

You're welcome!
Was browser.newtabpage.enabled already set to true or did you need to change it to true?
It was already set to true
(In reply to Yauhen Shulitski from comment #2)
> (the only one element on the page is Firefox logo in top left
> corner)

If it means the top-left part of the page (and not the favicon),
that might be a quirky bug.

Yauhen, is the Firefox logo grey or coloured?
Flags: needinfo?(jsnjack)
I believe it was grey. Also what I noticed is that the configuration page didn't have Firefox Home Content section. Only New Windows and Tabs section was presented
Flags: needinfo?(jsnjack)
Firefox Home Content section was not presented
The situation sounds like activity stream never got initialized to render the page or to render the preferences. There had been some extension sandboxing issues in the past that prevented the loading of the extension on Linux, but that was fixed in bug 1384240.

You wouldn't happen to still have the broken profile to see if there were errors that appeared in the Tools -> Web Developer -> Browser Console?
See Also: → 1384240
ahhh.. unfortunately, I don't have it anymore. I think it was removed during the Refresh process. 

When I visited about:newtab with open console, there was only one message:
Navigated to jar:file:///home/jsn/app/firefox/browser/features/activity-stream@mozilla.org.xpi!/chrome/content/prerendered/en-US/activity-stream.html
Component: New Tab Page → Activity Streams: Newtab
Priority: -- → P5
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.