Closed Bug 1460963 Opened 2 years ago Closed 11 months ago

New tab page in 60.0 loads blank

Categories

(Firefox :: New Tab Page, defect)

60 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox-esr60 --- wontfix
firefox60 - wontfix
firefox61 --- wontfix
firefox62 --- wontfix

People

(Reporter: xrysostom, Unassigned, NeedInfo)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Build ID: 20180503143129

Steps to reproduce:

Control+T 


Actual results:

Completely blank page loaded. Not even the gear icon appeared.


Expected results:

I have a slightly tweaked default setting and normally see my Top Sites and Recommended by Pocket displays along with the gear icon. Following the 60.0 update on my Win 7 desktop, they all disappeared. After a bit of online searching and crawling through about:config, I discovered that the browser.newtabpage.enabled preference was set to false. Resetting to true resolved the issue.
Component: Untriaged → New Tab Page
I can confirm this.

Affected versions: Firefox 60.0, Firefox 60.0.1 (64-bit) Official Release Version
OS: Windows 10 x64 v1803


- Start Firefox
- Every new open tab (Regardless of CMD+T, new tab button at the tab bar) is a completely blank page, not even the cogwheel at the upper-right.

I have different profiles, and they all are affected. Including a completely empty profile I have for testing purposes (no extensions, no changed settings (except cosmetic ones via the "customize" function from menu))

As mentioned by the reporter: Setting `browser.newtabpage.enabled` back to `true` in about:config fixed it.

BUT: There is one exception: One of my profiles has sync enabled, i.e. "Sign in to Sync" / "Firefox Account"
(as described here: https://support.mozilla.org/en-US/kb/how-do-i-set-sync-my-computer)

And this profile did NOT exhibit the issue described. I don't know why. But this is the only difference between the profiles I can think of right now.

Additional remark:

Also tested with Firefox Nightly (version from 2018-05-16), and this was also NOT affected as well..
This is an upgrade bug (and it stills exists on 60.0.1). Other scenarios (clean install, new profile) works fine.

Details:

This was run in an internal platform harness. It checks for the presence of the config flag found in user.js and reports fail if the config browser.newtabpage.enabled is explicitly marked false.

Upgrade Tests:
CheckSys Test Harness 0.4.2/20180510-Internal

Test ID: 2BB36434-BBA0-460D-9A16-431FF006A575
Test Started: 2018-05-19 00:32:48Z
Platform: Windows 10 April 2018 Update (10.0.1803.17104.48)
Test Type: Automatic
New version: Mozilla Firefox 60.0.1 x64 Official (Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0)
Old version: Mozilla Firefox 59.0.3 x64 Official (Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0)

Upgraded_Profile_Unsynced: failed test (12/12 fail)
Upgraded_Profile_Synced: inclonclusive (7/12 fail, 5/12 pass)
New_Profile: passed test (12/12 pass)

Test Ended: 2018-05-19 00:42:17Z

Clean Install Test:
CheckSys Test Harness 0.4.2/20180510-Internal

Test ID: D0DEA189-67D6-4776-98E6-709F4DC6F28E
Test Started: 2018-05-19 00:43:12Z
Platform: Windows 10 April 2018 Update (10.0.1803.17104.48)
Test Type: Automatic
Version: Mozilla Firefox 60.0.1 x64 Official (Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0)

Clean_Install: passed test (12/12 pass)

Test Ended: 2018-05-19 00:45:32Z
> This was run in an internal platform harness. It checks for the presence of
> the config flag found in user.js and reports fail if the config
> browser.newtabpage.enabled is explicitly marked false.

I mistyped user.js wheras the tested file was prefs.js (which is the correct
one, btw). I've checked my platform test and it was indeed prefs.js which was
tested and not user.js.
the browser.newtabpage.enabled preference didn't have an effect for a while, which was changed in firefox 60 with bug 1383599.

however there's a fairly large number of user reports describing the symptoms of a blank new tab page - in some cases people seem to unsure/unaware of how the pref got disabled in the first place. maybe it's worth investigating of how this has happened (some experiments or third-party interference) and how to mitigate this for users who got into this state unwillingly.

https://support.mozilla.org/en-US/questions/firefox?owner=all&tagged=bug1460963&show=all
https://old.reddit.com/r/firefox/comments/8ief7p/new_tab_is_suddenly_entirely_blank/
https://old.reddit.com/r/firefox/comments/8k4632/6001_newtab_a_blank/
https://old.reddit.com/r/firefox/comments/8k8oov/bug_new_tab_not_showing_home_page_anymore/
https://old.reddit.com/r/firefox/comments/8lgad3/broken_new_tab_functionality/
https://old.reddit.com/r/firefox/comments/8km9wj/after_updating_to_v6001_my_new_tab_page_is_just/
See Also: → 1383599
Ed, is this something you can look into?
Flags: needinfo?(edilee)
Did you previously turn off the new tab page when it was the previous layout / "Tiles" before Firefox 57?
Flags: needinfo?(edilee) → needinfo?(xrysostom)
Is it safe to mark these as duplicates of this?
Bug 1461035
Bug 1461079
Bug 1463726
(In reply to Ed Lee :Mardak from comment #6)
> Did you previously turn off the new tab page when it was the previous layout
> / "Tiles" before Firefox 57?

I have two set-ups that was created before Quantum versions were shipped: my
main profie (which was modified by a heavyweight theme:
https://addons.mozilla.org/en-US/firefox/addon/simplewhitex/ and have sync
enabled) and a "vanilla" profile that is never synced and only used for
website testing on a plain Firefox.

Both of them have experienced the bug. I won't be surpised on the main profile
but the secoondary profile also caught up the bug, which warrants investigation.
(In reply to Gingerbread Man from comment #7)
> Is it safe to mark these as duplicates of this?
> Bug 1461035
> Bug 1461079
> Bug 1463726

First bug closed (as for now), requests to reproduce the bug for the reporters
of the second and third bug has been sent with a pointer here.
(In reply to Gingerbread Man from comment #7)
> Is it safe to mark these as duplicates of this?
> Bug 1463726

The reporter of Bug 1463726 has just answered and it
is a more puzzling answer that I've expected
(https://bugzilla.mozilla.org/show_bug.cgi?id=1463726#c2).

It is a different bug.
It's not necessarily a different underlying bug. Bug 1454344 was fixed in 61 so that switching to/from "Blank Page" (i.e., browser.newtabpage.enabled true/false) happens immediately instead of on the 2nd new tab.
maybe we should remove the "browser.newtabpage.enabled" preference from being synced since it is no longer exposed in the ui in order to avoid any potential breakage that propagates this way.
The UI shows it from about:preferences > Home > New Windows and Tabs
oh ok (it's there starting from 61)
Duplicate of this bug: 1462917
Component: New Tab Page → Activity Streams: Newtab
Status: UNCONFIRMED → RESOLVED
Closed: 11 months ago
Resolution: --- → WONTFIX
Component: Activity Streams: Newtab → New Tab Page
You need to log in before you can comment on or make changes to this bug.