Closed Bug 1464473 Opened Last year Closed Last year

Update webrender to 3829687ffbe8d55885d71a3d5e5e79216251548f

Categories

(Core :: Graphics: WebRender, defect, P3)

62 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla62
Tracking Status
firefox62 --- fixed

People

(Reporter: kats, Assigned: kats)

References

(Blocks 2 open bugs, )

Details

(Whiteboard: [gfx-noted])

Attachments

(3 files)

+++ This bug was initially created as a clone of Bug #1463416 +++

I'm filing this as a placeholder bug for the next webrender update. I may be running a cron script [1] that does try pushes with webrender update attempts, so that we can track build/test breakages introduced by webrender on a rolling basis. This bug will hold the try push links as well as dependencies filed for those breakages, so that we have a better idea going into the update of what needs fixing. I might abort the cron job because once things get too far out of sync it's hard to fully automate fixing all the breakages.

When we are ready to actually land the update, we can rename this bug and use it for the update, and then file a new bug for the next "future update".

[1] https://github.com/staktrace/moz-scripts/blob/master/try-latest-webrender.sh
The reason I was having so much trouble with servo/webrender#2764 is because it introduced a #!allow(unused_variables) which cbindgen/syn barfs on. I've filed eqrion/cbindgen#169 for this.
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #1)
> The reason I was having so much trouble with servo/webrender#2764 is because
> it introduced a #!allow(unused_variables) which cbindgen/syn barfs on. I've
> filed eqrion/cbindgen#169 for this.

Hmm, "#!allow(unused_variables)" usage seems not good here. It needs to be "#allow(unused_variables)". Sorry about it.
No worries. Once I figured out what was going on it was pretty easy to deal with, and Emilio already landed a fix for it.

WR @ 52ba1165be4f69b84cbd35fdcf8841bff28822fa

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4cb8470807c1a0a518666dd5241c8d69502d3c66
https://treeherder.mozilla.org/#/jobs?repo=try&revision=1688c5b17d1f71854e0b788e37f938b50c88bf52

Green
WR @ 67f8715a719aeae408de76906a0798191ba6de70

https://treeherder.mozilla.org/#/jobs?repo=try&revision=12a0fba7254666c7dfba9f4b738093e076de2381

Much debug orange with this: thread 'WRRenderBackend#1' panicked at 'MEH: malicious process?: Custom("invalid value: integer `4093640704`, expected variant index 0 <= i < 20")', /checkout/src/libcore/result.rs:916:5

Regression range is:

*   67f8715a Auto merge of #2725 - kvark:chase2, r=gw3583
|\
| * 501c0265 Debug tracking of display items
* 9596f127 Auto merge of #2770 - kvark:document, r=gw3583
* 08eaa80a Fix document placement and scissoring
WR @ 67f8715a719aeae408de76906a0798191ba6de70

https://treeherder.mozilla.org/#/jobs?repo=try&revision=6f0fc7c453de0435913dcb756b3b38a2c285a47c
https://treeherder.mozilla.org/#/jobs?repo=try&revision=4adc0e563a2a3dd505f5fd9ec023436f46a767b7

Same as before. servo/webrender#2725 is being backed out to resolve this, but for now I'm going do an update to 3829687ffbe8d55885d71a3d5e5e79216251548f
Alias: wr-future-update
Assignee: nobody → bugmail
Summary: Future webrender update bug → Update webrender to 3829687ffbe8d55885d71a3d5e5e79216251548f
Comment on attachment 8981406 [details]
Bug 1464473 - Update webrender to 3829687ffbe8d55885d71a3d5e5e79216251548f.

https://reviewboard.mozilla.org/r/247528/#review253734
Attachment #8981406 - Flags: review?(a.beingessner) → review+
Comment on attachment 8981407 [details]
Bug 1464473 - Update for API change in WR PR 2764.

https://reviewboard.mozilla.org/r/247530/#review253736
Attachment #8981407 - Flags: review?(a.beingessner) → review+
Comment on attachment 8981408 [details]
Bug 1464473 - Update for API change in WR PR 2768.

https://reviewboard.mozilla.org/r/247532/#review253960
Attachment #8981408 - Flags: review?(nical.bugzilla) → review+
Pushed by kgupta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/84bcc6fa5f9c
Update webrender to 3829687ffbe8d55885d71a3d5e5e79216251548f. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/23da3fec993b
Update for API change in WR PR 2764. r=Gankro
https://hg.mozilla.org/integration/autoland/rev/e05689496378
Update for API change in WR PR 2768. r=nical
You need to log in before you can comment on or make changes to this bug.