Closed Bug 1464680 Opened 2 years ago Closed 2 years ago

Add WebRTC gn-configs for FreeBSD armv7 and OpenBSD aarch64

Categories

(Firefox Build System :: General: Unsupported Platforms, enhancement, P5)

enhancement

Tracking

(firefox-esr60 fixed, firefox61 fixed, firefox62 fixed)

RESOLVED FIXED
mozilla62
Tracking Status
firefox-esr60 --- fixed
firefox61 --- fixed
firefox62 --- fixed

People

(Reporter: jbeich, Assigned: jbeich)

References

Details

Attachments

(1 file)

Let's add more BSD configs even if untested in order to unblock Tier3 porting effort.
Attachment #8980979 - Flags: review?(dminor) → review?(core-build-config-reviews)
(In reply to Jan Beich from comment #2)
> https://reviewboard.mozilla.org/r/247116/diff/1-2/

That was rebase after bug 1465274.
Attachment #8980979 - Flags: review?(core-build-config-reviews) → review?(cmanchester)
Comment on attachment 8980979 [details]
Bug 1464680 - Add more WebRTC's gn-configs for BSDs on ARM.

https://reviewboard.mozilla.org/r/247116/#review254566
Attachment #8980979 - Flags: review?(cmanchester) → review+
Keywords: checkin-needed
Comment on attachment 8980979 [details]
Bug 1464680 - Add more WebRTC's gn-configs for BSDs on ARM.

Approval Request Comment
[ESR consideration]: ESR52 -> ESR60 regression and ESR being easier to support on non-x86/x86_64 due to less code churn each release. The patch here is very large, so downstream maybe reluctant to backport it.
[Feature/Bug causing the regression]: bug 1393119 regression
[User impact if declined]: Broken build on NetBSD/OpenBSD non-x86/x86_64 and FreeBSD non-x86/x86_64/aarch64 unless --disable-webrtc. Of those only OpenBSD aarch64 has Rust support.
[Is this code covered by automated tests?]: Yes, by dom/media/ tests. Not on Tier3 platforms.
[Has the fix been verified in Nightly?]: Partially on ESR60. media/webrtc/ builds fine on FreeBSD armv7/aarch64 and there're no FreeBSD-specific changes, so results can be extrapolated to NetBSD and OpenBSD.
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: bug 1465274 to fix merge conflict
[Is the change risky?]: No
[Why is the change risky/not risky?]: Can only break build
[String changes made/needed]: None
Attachment #8980979 - Flags: approval-mozilla-esr60?
Attachment #8980979 - Flags: approval-mozilla-beta?
Comment on attachment 8980979 [details]
Bug 1464680 - Add more WebRTC's gn-configs for BSDs on ARM.

Fixes build bustage for some Tier 3 platforms. Approved for 61.0b11 and ESR 60.1.
Attachment #8980979 - Flags: approval-mozilla-esr60?
Attachment #8980979 - Flags: approval-mozilla-esr60+
Attachment #8980979 - Flags: approval-mozilla-beta?
Attachment #8980979 - Flags: approval-mozilla-beta+
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/dcfbe51f171e
Add more WebRTC's gn-configs for BSDs on ARM. r=chmanchester
Keywords: checkin-needed
Assignee: nobody → jbeich
https://hg.mozilla.org/mozilla-central/rev/dcfbe51f171e
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.