webrtc compile failure on ppc64(le): g++: error: unrecognized command line option ‘-msse2'

RESOLVED FIXED in Firefox -esr60

Status

RESOLVED FIXED
10 months ago
10 months ago

People

(Reporter: spectre, Assigned: spectre)

Tracking

Trunk
mozilla62
Other
Unspecified

Firefox Tracking Flags

(firefox-esr60 fixed, firefox61 fixed, firefox62 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

10 months ago
Spun off from bug 1434589 per request, though the fix here will necessarily fix that bug as well, at least on Linux.
(Assignee)

Comment 1

10 months ago
Same patch as in that bug.
Assignee: nobody → spectre
Status: NEW → ASSIGNED
Attachment #8981683 - Flags: review?(nfroyd)
Comment on attachment 8981683 [details] [diff] [review]
Add ppc64 to webrtc, regenerate moz.build to remove SSE2 dependency for Linux

Review of attachment 8981683 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you!
Attachment #8981683 - Flags: review?(nfroyd) → review+
Keywords: checkin-needed

Comment 3

10 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/854d7b3f850d
Add ppc64 to webrtc, regenerate moz.build to remove SSE2 dependency for Linux. r=froydnj
Keywords: checkin-needed

Comment 4

10 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/854d7b3f850d
Status: ASSIGNED → RESOLVED
Last Resolved: 10 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla62
(Assignee)

Updated

10 months ago
See Also: → bug 1434589

Comment 5

10 months ago
Comment on attachment 8981683 [details] [diff] [review]
Add ppc64 to webrtc, regenerate moz.build to remove SSE2 dependency for Linux

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:  bug 1393119 regression
User impact if declined: Broken build on Linux non-x86/x86_64 unless --disable-webrtc. Here's a list of affected architectures:
https://searchfox.org/mozilla-central/rev/38bcf897f1fa/media/webrtc/trunk/build/build_config.h#110-173
Fix Landed on Version: Firefox 62
Risk to taking this patch (and alternatives if risky): No, can only break build on Linux at worst.
String or UUID changes made by this patch: None
Attachment #8981683 - Flags: approval-mozilla-esr60?

Comment 6

10 months ago
Comment on attachment 8981683 [details] [diff] [review]
Add ppc64 to webrtc, regenerate moz.build to remove SSE2 dependency for Linux

See comment 5. Probably less critical for non-ESR because rolling distributions rarely support non-x86/x86_64.
Attachment #8981683 - Flags: approval-mozilla-beta?
Comment on attachment 8981683 [details] [diff] [review]
Add ppc64 to webrtc, regenerate moz.build to remove SSE2 dependency for Linux

Needed for bug 1464680. Approved for 61.0b11 and ESR 60.1.
Attachment #8981683 - Flags: approval-mozilla-esr60?
Attachment #8981683 - Flags: approval-mozilla-esr60+
Attachment #8981683 - Flags: approval-mozilla-beta?
Attachment #8981683 - Flags: approval-mozilla-beta+

Comment 8

10 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/5b046ff33709
status-firefox61: --- → fixed

Comment 9

10 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr60/rev/af160715ee91
status-firefox-esr60: --- → fixed
You need to log in before you can comment on or make changes to this bug.