Remove most of the remaining stylo mentions from tests and such.

RESOLVED FIXED in Firefox 62

Status

()

enhancement
P3
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: emilio, Assigned: emilio)

Tracking

unspecified
mozilla62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(7 attachments)

No description provided.
Comment on attachment 8981488 [details]
Bug 1465107: Remove stylo mentions from wptrunner.

https://reviewboard.mozilla.org/r/247606/#review253650

Thanks!
Attachment #8981488 - Flags: review?(james) → review+
Comment on attachment 8981483 [details]
Bug 1465107: Cleanup remaining mochitest / reftest / crashtests stylo expectations.

https://reviewboard.mozilla.org/r/247596/#review253792
Attachment #8981483 - Flags: review?(xidorn+moz) → review+
Comment on attachment 8981484 [details]
Bug 1465107: Remove browser_newtab_share_rule_processors.js.

https://reviewboard.mozilla.org/r/247598/#review253794

Although this specific test is only relevant to the old style system, we may still want some similar mechanism for stylo as well... Not sure whether there is any bug opened for this.
Attachment #8981484 - Flags: review?(xidorn+moz) → review+
Comment on attachment 8981485 [details]
Bug 1465107: Remove stylo mentions from leftover WPT expectations.

https://reviewboard.mozilla.org/r/247600/#review253796
Attachment #8981485 - Flags: review?(xidorn+moz) → review+
Comment on attachment 8981486 [details]
Bug 1465107: Remove stylo from the reftest manifest parser.

https://reviewboard.mozilla.org/r/247602/#review253800
Attachment #8981486 - Flags: review?(xidorn+moz) → review+
Comment on attachment 8981487 [details]
Bug 1465107: Remove stylo mentions from the mochitest runner.

https://reviewboard.mozilla.org/r/247604/#review253802

::: testing/mochitest/runtests.py
(Diff revision 1)
>          tests = []
>          manifest = self.getTestManifest(options)
>          if manifest:
>              if options.extra_mozinfo_json:
>                  mozinfo.update(options.extra_mozinfo_json)
> -            if 'STYLO_FORCE_ENABLED' in os.environ:

Maybe we should also remove all the mentions of "STYLO_FORCE_ENABLED"?
Attachment #8981487 - Flags: review?(xidorn+moz) → review+
Comment on attachment 8981489 [details]
Bug 1465107: Remove isStyledByServo.

https://reviewboard.mozilla.org/r/247608/#review253804

::: dom/smil/test/db_smilCSSFromBy.js:28
(Diff revision 2)
>      // The "from" and "by" values in the test case below overflow the maxium
>      // color-channel values when added together.
>      // (e.g. for red [ignoring alpha for now], 100 + 240 = 340 which is > 255)
>      // The SVG Animation spec says we should clamp color values "as late as
>      // possible" i.e. allow the channel overflow and clamp at paint-time.
>      //
>      // Servo does this, and gives us:
>      //
>      //   to-value = (rgb(100, 100, 100) * 0.6 + rgb(240, 240, 240) * 1.0)) * 1
>      //            = rgb(300, 300, 300)
>      //   midComp  = (rgb(100, 100, 100) * 0.6 * 0.5 + rgb(300, 300, 300) * 1.0 * 0.5) * (1 / 0.8)
>      //            = rgb(225, 225, 225)
>      //
>      // Gecko, however, clamps the "to" value and interpolates up to that
>      // clamped result giving:
>      //
>      //   midComp  = (rgb(100, 100, 100) * 0.6 * 0.5 + rgb(255, 255, 255) * 1.0 * 0.5) * (1 / 0.8)
>      //            = rgb(197, 197, 197)
>      //



::: dom/smil/test/db_smilCSSFromBy.js:28
(Diff revision 3)
>      // The "from" and "by" values in the test case below overflow the maxium
>      // color-channel values when added together.
>      // (e.g. for red [ignoring alpha for now], 100 + 240 = 340 which is > 255)
>      // The SVG Animation spec says we should clamp color values "as late as
>      // possible" i.e. allow the channel overflow and clamp at paint-time.
>      //
>      // Servo does this, and gives us:
>      //
>      //   to-value = (rgb(100, 100, 100) * 0.6 + rgb(240, 240, 240) * 1.0)) * 1
>      //            = rgb(300, 300, 300)
>      //   midComp  = (rgb(100, 100, 100) * 0.6 * 0.5 + rgb(300, 300, 300) * 1.0 * 0.5) * (1 / 0.8)
>      //            = rgb(225, 225, 225)
>      //
>      // Gecko, however, clamps the "to" value and interpolates up to that
>      // clamped result giving:
>      //
>      //   midComp  = (rgb(100, 100, 100) * 0.6 * 0.5 + rgb(255, 255, 255) * 1.0 * 0.5) * (1 / 0.8)
>      //            = rgb(197, 197, 197)
>      //

This comment needs update, probably remove the section about Gecko or mention it as an example of wrong result.

::: layout/inspector/tests/test_getRelativeRuleLine.html:31
(Diff revision 3)
>       }
>    </style>
>    <script type="application/javascript">
>    const InspectorUtils = SpecialPowers.InspectorUtils;
>  
> -  const supportsRuleColumn = SpecialPowers.DOMWindowUtils.isStyledByServo ? 14
> +  const supportsRuleColumn = 14;

You can replace the only usage of this constant below with the number directly. This constant was added solely for distinguishing between stylo and gecko.

::: layout/style/test/property_database.js:512
(Diff revision 3)
>  // Gradient values that are incorrectly accepted in Gecko, but are correctly
>  // rejected with Servo's style-system backend (stylo):
>  let gradientsNewlyRejectedInStylo = [
>    "radial-gradient(circle red, blue)",
>  ];

This can be removed as well.

::: layout/style/test/property_database.js:6662
(Diff revision 3)
>  
> -  // See https://github.com/w3c/fxtf-drafts/issues/228.
> -  //
> -  // This is updated in Stylo but not Gecko.
> -  if (SpecialPowers.DOMWindowUtils.isStyledByServo) {
> -    gCSSProperties["filter"].other_values.push("hue-rotate(0)");
> +  gCSSProperties["filter"].other_values.push("hue-rotate(0)");

This can be added to the list above directly.

::: layout/style/test/test_specified_value_serialization.html:127
(Diff revision 3)
> -    // Servo keeps the original prefix form which is closer to other impls.
> +  // Servo keeps the original prefix form which is closer to other impls.
> -    backgroundImages.push([
> +  backgroundImages.push([
> -      "-webkit-radial-gradient(contain, red, blue)",
> +    "-webkit-radial-gradient(contain, red, blue)",
> -      "-webkit-radial-gradient(center center, closest-side, red, blue)",
> +    "-webkit-radial-gradient(center center, closest-side, red, blue)",
> -      "-webkit-radial-gradient with legacy 'contain' keyword",
> +    "-webkit-radial-gradient with legacy 'contain' keyword",
> -    ]);
> +  ]);

This can be merged into the list above directly.

::: layout/style/test/test_transitions_per_property.html:62
(Diff revision 3)
>  }
>  
>  var FUNC_NEGATIVE = "cubic-bezier(0.25, -2, 0.75, 1)";
>  var FUNC_OVERONE = "cubic-bezier(0.25, 0, 0.75, 3)";
>  
>  // After resolving Bug 1387080, we can remove this variable.

This comment should be removed as well.
Attachment #8981489 - Flags: review?(xidorn+moz) → review+
Priority: -- → P3
Pushed by ecoal95@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0c4a88e5c0b8
Cleanup remaining mochitest / reftest / crashtests stylo expectations. r=xidorn
https://hg.mozilla.org/integration/mozilla-inbound/rev/06dbf8f88931
Remove browser_newtab_share_rule_processors.js. r=xidorn
https://hg.mozilla.org/integration/mozilla-inbound/rev/c2e25ea34776
Remove stylo mentions from leftover WPT expectations. r=xidorn
https://hg.mozilla.org/integration/mozilla-inbound/rev/2b4be8fa1e9d
Remove stylo from the reftest manifest parser. r=xidorn
https://hg.mozilla.org/integration/mozilla-inbound/rev/5a263f066765
Remove stylo mentions from the mochitest runner. r=xidorn
https://hg.mozilla.org/integration/mozilla-inbound/rev/695729f6c9a6
Remove stylo mentions from wptrunner. r=jgraham
https://hg.mozilla.org/integration/mozilla-inbound/rev/9791b3b0efc9
Remove isStyledByServo. r=xidorn
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/11241 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Upstream PR merged
Duplicate of this bug: 1452512
You need to log in before you can comment on or make changes to this bug.