Bug 1395112 (stylo-everywhere)

Remove the old style system (and use Stylo everywhere)

RESOLVED FIXED

Status

()

P2
normal
RESOLVED FIXED
2 years ago
2 months ago

People

(Reporter: hsivonen, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 9 bugs)

Firefox Tracking Flags

(firefox57 wontfix)

Details

(Reporter)

Description

2 years ago
Once stylo is enabled on all platforms, we should remove the old style system in the interest of clean-ups and code size.
(Reporter)

Updated

2 years ago
Blocks: 1395114
No longer blocks: 1395114
Depends on: 1374034, 1294570
status-firefox57: --- → wontfix
Priority: -- → P3
Depends on: 1345025
Depends on: 1406274
Alias: stylo-everywhere
Summary: Remove the old style system → Remove the old style system (and use Stylo everywhere)
Blocks: 1407527
Depends on: 1408300
Depends on: 1408303
Depends on: 1408305
Depends on: 1408308
Depends on: 1408310
Depends on: 1408311
Depends on: 1408312
Depends on: 1408322
Depends on: 1409278
Depends on: 1345702
Depends on: 1418216
Depends on: 1418217
Depends on: 1418222
Depends on: 1418232
Depends on: 1418245
Depends on: 1418872
Depends on: 1418874
Depends on: 1418899
Depends on: 1418905
Depends on: 1419645
Depends on: 1419709
Depends on: 1390583
No longer depends on: 1418874
Depends on: 1420026
Depends on: 1420039
Depends on: 1420056
Depends on: 1420071
Depends on: 1420113
Depends on: 1420117
Depends on: 1420379
Depends on: 1420383
Depends on: 1338944
No longer depends on: 1338944
I have some WIP patches to remove the old style system code, and it results in libxul.so shrinking by 993 KiB.
(On Linux x64.)
Tested again, with --enable-release:

stylo:disabled, old style:enabled  - 87,884,896
stylo:enabled,  old style:enabled  - 93,660,448
stylo:enabled,  old style:disabled - 92,906,592

So only around 736 KB.  And the size regression from enabling stylo is more like 5.5 MiB.

Updated

a year ago
Blocks: 435426
P2 because we need to remove (or at least disable at compile-time) the old style system code before we ship Stylo-android or Stylo-chrome.
Priority: P3 → P2
Isn’t it the reverse? Don’t we need to stop using the old style system (on Android and in chrome) before we disable/remove it?
(In reply to Simon Sapin (:SimonSapin) from comment #5)
> Isn’t it the reverse? Don’t we need to stop using the old style system (on
> Android and in chrome) before we disable/remove it?

Yeah. I just meant that we want to disable the old style system in the same release we ship on Android and in chrome.
Depends on: 1430014
No longer blocks: 1426223
Depends on: 1434130
Depends on: 1437695
Depends on: 1443471
Depends on: 1444221
No longer depends on: 1345702
Depends on: 1444905
We didn't wait for mingw builds to be fixed (bug 1390583 and bug 1443471). Instead the mingw builds are being disabled for now (bug 1447414).
No longer depends on: 1390583, 1443471
Blocks: 1447627
Blocks: 1421509
Depends on: 1448757
Depends on: 1449068
Depends on: 1418874
No longer depends on: 1418874
Depends on: 1410184
Depends on: 1418874
Depends on: 1449087
No longer blocks: 1448759
No longer depends on: 1410184

Fixed, right?

Flags: needinfo?(emilio)

Yup!

Status: NEW → RESOLVED
Last Resolved: 2 months ago
Flags: needinfo?(emilio)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.