Title bar and drag space text in customize mode with dark theme can't be read on hovering

RESOLVED FIXED in Firefox 62

Status

()

defect
P3
normal
RESOLVED FIXED
Last year
Last year

People

(Reporter: clement.lefevre, Assigned: dao)

Tracking

({nightly-community})

unspecified
Firefox 62
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 wontfix, firefox60 wontfix, firefox61 wontfix, firefox62 fixed)

Details

(Whiteboard: [mozfr-community])

Attachments

(2 attachments)

See the joined video, when user is hovering title bar or drag space text in the customize mode, the text is using same color as background, and therefore become impossible to read.
Whiteboard: [mozfr-community]
Component: Theme → Toolbars and Customization
What platform/OS are you using? Can you share more of your build information? I'm unable to reproduce this on 62.0a1 (2018-05-30) (64-bit) Windows 10 with the Dark theme enabled.
Flags: needinfo?(clement.lefevre)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #1)
> What platform/OS are you using? Can you share more of your build
> information? I'm unable to reproduce this on 62.0a1 (2018-05-30) (64-bit)
> Windows 10 with the Dark theme enabled.

Video was recorded on Archlinux with latest Gnome/GTK and using the latest nightly.
Flags: needinfo?(clement.lefevre)
Thanks, can you run mozregression[1] to see if this is a recent regression? If we can narrow down when this started happening it will be much easier to fix. 

[1] http://mozilla.github.io/mozregression/
Flags: needinfo?(clement.lefevre)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #3)
> Thanks, can you run mozregression[1] to see if this is a recent regression?
> If we can narrow down when this started happening it will be much easier to
> fix. 
> 
> [1] http://mozilla.github.io/mozregression/

Arrived on https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9f8b177edf71215098643f5a705fe8730734c346&tochange=63224d6e543cc3399f419dd4ac500873db02b021 which probably is the commit that introduced those options: I was able to reproduce it on every build with the options existing.
Flags: needinfo?(clement.lefevre)
Thanks, I won't mark this as a regression since this was basically broken on your setup since the feature was introduced. I don't think this change actually caused the problem, it may have just made the problem visible.
Blocks: 1415481
Priority: -- → P3
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
It looks like something changed on the Gtk side with regards to how checkboxes are rendered. They used to get a solid background on hover (which always felt weird) and so we also set a text color for the hover state.
Comment on attachment 8982581 [details]
Bug 1465497 - Stop setting a color on hovered checkboxes and radio buttons.

https://reviewboard.mozilla.org/r/248562/#review254780
Attachment #8982581 - Flags: review?(jaws) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/330f40fac3e8
Stop setting a color on hovered checkboxes and radio buttons. r=jaws
https://hg.mozilla.org/mozilla-central/rev/330f40fac3e8
Status: ASSIGNED → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Hi Clément, this fix should be available in the latest Nightly builds. Can you confirm that this is working better for you now? Thanks!
Flags: needinfo?(clement.lefevre)
Yes it's fixed for me.

However, there's two things to take care about too:

- I'm using latest Gnome/GTK, and :dao seemed to say this could have been caused by changes on their side. For that reason, I think it would be nice to check it on older Gnome/GTKs. I don't have some at hand, so it would require other people to check this out.

- When clicking the checkboxes, it now presents a text-decoration all around the text, is that normal?
Flags: needinfo?(ryanvm)
Flags: needinfo?(dao+bmo)
Flags: needinfo?(clement.lefevre)
(In reply to Clément Lefèvre from comment #12)
> Yes it's fixed for me.
> 
> However, there's two things to take care about too:
> 
> - I'm using latest Gnome/GTK, and :dao seemed to say this could have been
> caused by changes on their side. For that reason, I think it would be nice
> to check it on older Gnome/GTKs. I don't have some at hand, so it would
> require other people to check this out.

I think we can just let this ride 63 train to catch such cases.

> - When clicking the checkboxes, it now presents a text-decoration all around
> the text, is that normal?

The focus ring? Yes, that's normal.
Flags: needinfo?(ryanvm)
Flags: needinfo?(dao+bmo)
(In reply to Dão Gottwald [::dao] from comment #13)
> (In reply to Clément Lefèvre from comment #12)
> > Yes it's fixed for me.
> > 
> > However, there's two things to take care about too:
> > 
> > - I'm using latest Gnome/GTK, and :dao seemed to say this could have been
> > caused by changes on their side. For that reason, I think it would be nice
> > to check it on older Gnome/GTKs. I don't have some at hand, so it would
> > require other people to check this out.
> 
> I think we can just let this ride 63 train to catch such cases.

Oops, I meant 62. I.e. no uplift, just let this bake in Nightly and then Beta.
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.