Add the 'mozillaAddons' Permission to Screenshots

VERIFIED FIXED in Firefox -esr60

Status

()

defect
VERIFIED FIXED
11 months ago
10 months ago

People

(Reporter: bchen, Assigned: bchen)

Tracking

unspecified
Firefox 62
Points:
---

Firefox Tracking Flags

(firefox-esr6061+ verified, firefox60 wontfix, firefox61+ verified, firefox62+ verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

11 months ago
Bug 1456485 introduced a new addon permission, 'mozillaAddons', that needs to be in Screenshots.
Note that we need this on ESR60 and Beta as well.
Comment hidden (mozreview-request)

Comment 3

11 months ago
mozreview-review
Comment on attachment 8981972 [details]
Bug 1465544 - Add 'mozillaAddons' permission to Screenshots;

https://reviewboard.mozilla.org/r/247990/#review254116
Attachment #8981972 - Flags: review?(ianb) → review+
Comment on attachment 8981972 [details]
Bug 1465544 - Add 'mozillaAddons' permission to Screenshots;

https://reviewboard.mozilla.org/r/247990/#review254120
Attachment #8981972 - Flags: review+

Comment 5

11 months ago
Pushed by jhirsch@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/04e69f74afe1
Add 'mozillaAddons' permission to Screenshots; r=ianbicking,_6a68

Comment 6

11 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/04e69f74afe1
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
Please request Beta & ESR60 approval on this patch.
Flags: needinfo?(bchen)
(Assignee)

Updated

11 months ago
Flags: needinfo?(bchen)
Attachment #8981972 - Flags: approval-mozilla-esr60?
Attachment #8981972 - Flags: approval-mozilla-beta?
(Assignee)

Comment 8

11 months ago
Comment on attachment 8981972 [details]
Bug 1465544 - Add 'mozillaAddons' permission to Screenshots;

> Approval Request Comment
> [Feature/Bug causing the regression]:
Bug 1456485 and bug 1466349.

> [User impact if declined]:
Users will not be able to take screenshots of PDFs with Firefox Screenshots.

> [Is this code covered by automated tests?]:
No, in that there's no full integration testing for capturing a shot of a PDF page.

> [Has the fix been verified in Nightly?]:
No.

> [Needs manual test from QE? If yes, steps to reproduce]: 
Yes. Bug 1456485 has the STR.

> [List of other uplifts needed for the feature/fix]:
Bug 1456485 and bug 1466349.

> [Is the change risky?]:
For Screenshots itself, no.  It fixes a regression.  See bug 1456485 for discussion on potential risks.

> [Why is the change risky/not risky?]:
It allows system addons to access protected pages. See bug 1456485.

> [String changes made/needed]:
No.
Comment on attachment 8981972 [details]
Bug 1465544 - Add 'mozillaAddons' permission to Screenshots;

Required fix to get Screenshots working again with various privileged pages (PDF Viewer, Reader Mode, etc). Approved for 61.0b12 and ESR 60.1.
Attachment #8981972 - Flags: approval-mozilla-esr60?
Attachment #8981972 - Flags: approval-mozilla-esr60+
Attachment #8981972 - Flags: approval-mozilla-beta?
Attachment #8981972 - Flags: approval-mozilla-beta+
I have verified this issue on the latest Nightly (62.0a1 Build ID: 20180617220505) and latest Beta (61.0b14 Build ID: 20180614135649) and the issue is no longer reproducible.
Tested on Windows 7 x64, Windows 10 x64, Mac Os 10.13 and Arch Linux.

The issue is still reproducible on Firefox ESR 60.0 because of bug 1467924 that should also be uplifted in ESR 60 (see bug 1467924 comment 10).
I have verified the issue on latest ESR (60.1.0, Build ID 20180621121604) and the issue is no longer reproducible. Tested on Windows 10 x64, Windows 7 x64, Mac 10.13 and Arch Linux 4.12.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.