Export Screenshots 33.0.0

RESOLVED FIXED in Firefox 62

Status

()

RESOLVED FIXED
10 months ago
9 months ago

People

(Reporter: bchen, Assigned: bchen)

Tracking

unspecified
Firefox 62
Points:
---

Firefox Tracking Flags

(firefox62 fixed)

Details

Attachments

(5 attachments)

(Assignee)

Description

10 months ago
This is an export of Screenshots 32.2.0.

Changelog is at https://github.com/mozilla-services/screenshots/commit/daf6bbe30c0eedd5cf8475a706e55ca5cd3e8510.

Note that the 'mozillaAddons' permission change is being added in Bug 1465544.

### Add-on changes

* Update copy icon in notifications. ([#4485](https://github.com/mozilla-services/screenshots/issues/4485)) [7eecffc](https://github.com/mozilla-services/screenshots/commit/7eecffc)
* Update dependency raven-js to v3.25.2 ([#4428](https://github.com/mozilla-services/screenshots/issues/4428)) [e71b139](https://github.com/mozilla-services/screenshots/commit/e71b139)
* Ignore download canceled by user errors. Fixes [#3964](https://github.com/mozilla-services/screenshots/issues/3964) [9eb7f6c](https://github.com/mozilla-services/screenshots/commit/9eb7f6c)
* Avoid including blank scrollbar area in save-visible shots. Fixes [#4147](https://github.com/mozilla-services/screenshots/issues/4147) [e081c42](https://github.com/mozilla-services/screenshots/commit/e081c42)
* Make onboarding behaviour consistent ([#4342](https://github.com/mozilla-services/screenshots/issues/4342)). Fixes [#4183](https://github.com/mozilla-services/screenshots/issues/4183) [236e16d](https://github.com/mozilla-services/screenshots/commit/236e16d)
* Use WebExtension page action instead of Photon. ([#3756](https://github.com/mozilla-services/screenshots/issues/3756)) ([#3967](https://github.com/mozilla-services/screenshots/issues/3967)) [02b4c6e](https://github.com/mozilla-services/screenshots/commit/02b4c6e)
* Use precision select cursor ([#4361](https://github.com/mozilla-services/screenshots/issues/4361)). Fixes [#4187](https://github.com/mozilla-services/screenshots/issues/4187) [8208c0b](https://github.com/mozilla-services/screenshots/commit/8208c0b)

### Clean-up and Lint

* Clean up log.js [17341d4](https://github.com/mozilla-services/screenshots/commit/17341d4)
* Upgrade eslint-plugin-mozilla along with code fixes. ([#4322](https://github.com/mozilla-services/screenshots/issues/4322)) [ff9aa53](https://github.com/mozilla-services/screenshots/commit/ff9aa53)

### Localization

* Initialize en-CA content, copying over en-GB ([#4388](https://github.com/mozilla-services/screenshots/issues/4388)) [d818d86](https://github.com/mozilla-services/screenshots/commit/d818d86)
(Assignee)

Comment 1

10 months ago
The original version number in the description was incorrect: it should've been 33.0.0.  The patch will have the correct version number.
Summary: Export Screenshots 32.2.0 → Export Screenshots 33.0.0
Comment hidden (mozreview-request)

Comment 6

10 months ago
mozreview-review
Comment on attachment 8982026 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (upgrade Raven to 3.25.2);

https://reviewboard.mozilla.org/r/248078/#review254176
Attachment #8982026 - Flags: review?(ianb) → review+

Comment 7

10 months ago
mozreview-review
Comment on attachment 8982025 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (translations only);

https://reviewboard.mozilla.org/r/248076/#review254178
Attachment #8982025 - Flags: review?(ianb) → review+

Comment 8

10 months ago
mozreview-review
Comment on attachment 8982027 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (code excluding translations and Raven update);

https://reviewboard.mozilla.org/r/248080/#review254182
Attachment #8982027 - Flags: review?(ianb) → review+

Comment 9

10 months ago
mozreview-review
Comment on attachment 8982025 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (translations only);

https://reviewboard.mozilla.org/r/248076/#review254324
Attachment #8982025 - Flags: review?(francesco.lodolo) → review+
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
The Talos data has some concerning regressions (see screenshot):

tp5o responsiveness opt e10s stylo: 17% (linux64), 12% (win10-64)
tabpaint opt e10s stylo: 5% (linux64)

Looking at a graph of recent results for the tp5o responsiveness test, that regression is definitely above the trend line. (I'll attach a second screenshot of the graph)

I think we should try reverting the change from Photon to WebExtension page action, and see if that removes the regressions.
Attached is the trend graph for linux64 tp5o responsiveness from the past 2 days. The trend line is fairly consistent; our results look to be a definite regression.

How to read this graph:

- highlighted purple dots: the 5 runs from this push (their average is 17%)
- other purple dots: other recent try Talos runs. ignore them
- orange dots: results from recent mozilla-central Talos runs
:chenba pointed out that we discussed these regressions in the pull request on Github: https://github.com/mozilla-services/screenshots/pull/3967

In that discussion, :kmag was not too concerned about the responsiveness regressions: https://github.com/mozilla-services/screenshots/pull/3967#issuecomment-379069692
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
The interdiffs look reasonable to me; merging.

Thanks again for taking on this chore, Barry 
Comment on attachment 8982027 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (code excluding translations and Raven update);

https://reviewboard.mozilla.org/r/248080/#review258602
Attachment #8982027 - Flags: review+
Comment on attachment 8982027 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (code excluding translations and Raven update);

https://reviewboard.mozilla.org/r/248080/#review258604
Comment on attachment 8982026 [details]
Bug 1465581 - Export Screenshots 33.0.0 to Firefox (upgrade Raven to 3.25.2);

https://reviewboard.mozilla.org/r/248078/#review258606

Looks like changing the MozReview-Commit-ID cleared the R+. Trying to re-R+ so I can autoland this.
Attachment #8982026 - Flags: review+

Comment 33

9 months ago
Pushed by jhirsch@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5d075fe82827
Export Screenshots 33.0.0 to Firefox (translations only); r=flod,ianbicking
https://hg.mozilla.org/integration/autoland/rev/3dda0c68e6bd
Export Screenshots 33.0.0 to Firefox (upgrade Raven to 3.25.2); r=ianbicking,_6a68
https://hg.mozilla.org/integration/autoland/rev/3f8b00d17eea
Export Screenshots 33.0.0 to Firefox (code excluding translations and Raven update); r=ianbicking,_6a68

Comment 34

9 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/5d075fe82827
https://hg.mozilla.org/mozilla-central/rev/3dda0c68e6bd
https://hg.mozilla.org/mozilla-central/rev/3f8b00d17eea
Status: NEW → RESOLVED
Last Resolved: 9 months ago
status-firefox62: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 62
You need to log in before you can comment on or make changes to this bug.