Closed Bug 1465730 Opened Last year Closed Last year

arrowscrollbox scroll buttons are intermittently rendered as disabled or enabled when they should have the opposite state

Categories

(Toolkit :: XUL Widgets, defect, P3)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1375012
Tracking Status
firefox62 --- affected

People

(Reporter: Paolo, Unassigned)

References

Details

Attachments

(1 obsolete file)

+++ This bug was initially created as a clone of Bug #1375012 +++

See bug 1368208 comment 56:

> I think I'll land this with 508816-1.xul disabled. The scroll buttons seem
> to suffer from some weird invalidation bug that I can reproduce even in
> nightly (e.g. in the all tabs list or in the bookmarks menu). My patch
> doesn't seem to make this worse but changes the timing such the reftest now
> exposes this bug.

I added some logging to _updateScrollButtonsDisabledState to see if it enables/disables the buttons as expected. It does do so, i.e. the buttons' disabled attributes get updated, but it seems that somehow this doesn't necessarily get rendered.
Note that once bug 1465457 is fixed, we may be able to use promiseDocumentFlushed and other privileged methods and see if they helps here.
Depends on: 1465457
No longer depends on: 1375012
Moved this together with the patch in bug 1375012 since these both depend on bug 1465457.
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → DUPLICATE
Duplicate of bug: 1375012
Attachment #8982198 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.