Closed Bug 1466038 Opened Last year Closed Last year

Upgrade Firefox 61 to use NSS 3.37.3

Categories

(Core :: Security: PSM, enhancement)

enhancement
Not set

Tracking

()

RESOLVED FIXED
mozilla61
Tracking Status
firefox61 + fixed
firefox62 --- unaffected

People

(Reporter: franziskus, Assigned: franziskus)

References

Details

Attachments

(1 file, 1 obsolete file)

Because of bug 1461731 a new NSS release (3.37.2) for uplift to Firefox 61 was requested.

This release includes fixes for
* bug 1461731 
* bug 1459739
When do you need the release?
Flags: needinfo?(ryanvm)
Unless you could have it ready now-ish (building 61.0b11 later today), my next build isn't until Thursday.
Flags: needinfo?(ryanvm)
Attached file upgrade-nss (obsolete) —
Approval Request Comment
[Feature/Bug causing the regression]: This fixes two NSS issues: bug 1461731 (Firefox can crash on WebAuthn or PK11 interaction on macOS) and bug 1459739 (build issue on non-intel architectures)
[User impact if declined]: Firefox can crash on WebAuthn or PK11 interaction on macOS
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: -
[Is the change risky?]: No
[Why is the change risky/not risky?]: The code changes are small and have been tested on other Firefox branches.
[String changes made/needed]: -
Attachment #8983327 - Flags: approval-mozilla-beta?
Attached file upgrade-nss
Sorry messed up version numbers.

Approval Request Comment
[Feature/Bug causing the regression]: This fixes two NSS issues: bug 1461731 (Firefox can crash on WebAuthn or PK11 interaction on macOS) and bug 1459739 (build issue on non-intel architectures)
[User impact if declined]: Firefox can crash on WebAuthn or PK11 interaction on macOS
[Is this code covered by automated tests?]: No
[Has the fix been verified in Nightly?]: Yes
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: -
[Is the change risky?]: No
[Why is the change risky/not risky?]: The code changes are small and have been tested on other Firefox branches.
[String changes made/needed]: -
Attachment #8983327 - Attachment is obsolete: true
Attachment #8983327 - Flags: approval-mozilla-beta?
Attachment #8983347 - Flags: approval-mozilla-beta?
Summary: Upgrade Firefox 61 to use NSS 3.37.2 → Upgrade Firefox 61 to use NSS 3.37.3
Comment on attachment 8983347 [details]
upgrade-nss

Needed to fix a WebAuthn crash on OSX. Approved for 61.0b12.
Attachment #8983347 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/5b52d28b7506
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla61
You need to log in before you can comment on or make changes to this bug.