Problem with location bar text entry when new instance opened

RESOLVED WORKSFORME

Status

SeaMonkey
Location Bar
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Lee Sam, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
When a browser is opened, minimized, and then another opened via application
start(double clicking), the second broser window won't allow text to be typed
into the location bar. This is a problem that appears when a mozilla browser is
open, regardless whether any tabs are used or not. 

Browser: Mozilla 1.0 RC3

Steps to reproduce:

1. Open Mozilla, borwse to any page.
2. Minimize window.
3. Open new instance of browser via double-clicking on an icon (or start however
else)
4. try to type in location bar

Comment 1

16 years ago
I also have this problem, but I've noticed it's worse when my "home" page is set
to Google or my Yahoo Mail home; both pages use Javascript to change the focus
to one of the fields in the document.  There's a roughly 1 in 3 chance that
opening a new browser window to either of these addresses will disable all text
fields (or at least make it impossible to enter any text in them) and the
location bar. 

Test URLs:
http://www.google.com/
http://mail.yahoo.co.uk/

For what it's worth, I've had problems with this bug since 0.99, long before the
RC builds.  Closing the browser window and opening a new one almost always
succeeds (that is, the second window always allows me to type in the location
bar, and since mailnews also opens a window on application start for me, I don't
have to quit out completely).  

I'm now using RC3 on WinXP with the same bug.  It's horrendously annoying. 

Comment 2

16 years ago
Looks like bug 140413 is a dupe of this, and is possibly related to bug 88689?
This is all I could find in my (admittedly brief) search for duplicates. 
(Reporter)

Comment 3

16 years ago
If it's related to 88689, then maybe it's a Javascript issue causing trouble
with the frontend then? Jsut a thought, haven't looked at the code yet.
(Reporter)

Comment 4

16 years ago
There are a few bugs which have similar descriptions:

location bar unselectable when new window is spawned:
http://bugzilla.mozilla.org/show_bug.cgi?id=146853

Occasionally unable to get Focus set to URL bar and other text fields:
http://bugzilla.mozilla.org/show_bug.cgi?id=126843

Comment 5

16 years ago
*** Bug 157174 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
*** Bug 146853 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
Is this bug still valid? I haven't dealt with it in ages.

I recall finding that the problem was that another instance of mozilla.exe (in
Windows NT or 2000?) was running. I just killed off that instance and the bug
went away.

Maybe the issue is having Mozilla recognize that there are other instances of
itself running, and deal with it appropriately.

Comment 8

12 years ago
steps-to-reproduce in comment 0 were bug 82534

resolving WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.