Closed Bug 1467132 Opened 4 years ago Closed 4 years ago

[Wayland/Clipboard] Second image data copy fails - broken pipe

Categories

(Core :: Widget: Gtk, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox62 --- affected

People

(Reporter: stransky, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Reproduction steps:

- copy any image to clipboard (right click menu -> Copy image), paste to gimp
- copy anything else to clipboard (text, link...)
- copy another image to clipboard (right click menu -> Copy image) -> Fails, the new image is not stored
Attached file test5.c
There's also a simple testcase which demonstrates that.
It may be caused by something else - looks like the first image is replicated to the cliboard and the second one is ignored.
Hm after some debugging it's really the https://gitlab.gnome.org/GNOME/gtk/issues/66 - I see the broken pipe again.
Duplicate of this bug: 1485916
Summary: [Wayland/Clipboard] Second image data copy fails → [Wayland/Clipboard] Second image data copy fails - broken pipe
That should be fixed now along the recent clipboard fixes at Wayland code.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.