Main window's close (X) button turns grey when opening the Add/Edit Bookmark popup

VERIFIED FIXED in Firefox 62

Status

()

P2
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: itiel_yn8, Assigned: dao)

Tracking

(Blocks: 1 bug, {regression})

unspecified
Firefox 63
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox-esr60 wontfix, firefox60 wontfix, firefox61 wontfix, firefox62 verified, firefox63 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 months ago
Created attachment 8984744 [details]
Screencast

Using Windows 10 x86 build 1803 & latest Nightly.

STR:
1. Open any webpage
2. Click the bookmark icon in the URL bar

AR:
Nightly's X button turns grey

ER:
Button stays in white

See attached GIF.

Regression range is 2018-03-09 to 2018-03-10.

2018-06-10T17:22:02: DEBUG : Starting merge handling...
2018-06-10T17:22:02: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=275400cc371d1710e698f60d350f436e1d4e4349&full=1
2018-06-10T17:22:03: DEBUG : Found commit message:
Bug 1441102 - Replace --titlebar-text-color with a class. r=florian

MozReview-Commit-ID: 9ruAARse3LU

2018-06-10T17:22:03: INFO : The bisection is done.
(Reporter)

Updated

5 months ago
Flags: needinfo?(dao+bmo)

Updated

5 months ago
Blocks: 1441102
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox60: --- → wontfix
status-firefox61: --- → affected
status-firefox62: --- → affected
status-firefox-esr52: --- → unaffected
status-firefox-esr60: --- → fix-optional
(Assignee)

Updated

5 months ago
Priority: -- → P2
status-firefox61: affected → wontfix
status-firefox62: affected → fix-optional
status-firefox-esr60: fix-optional → wontfix
(Assignee)

Updated

5 months ago
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 1

5 months ago
This is happening because the bookmark panel actually disables the close window command:

https://searchfox.org/mozilla-central/rev/d2966246905102b36ef5221b0e3cbccf7ea15a86/browser/base/content/browser-places.js#50-69

IMHO we should drop this behavior. From what I can tell it doesn't really work anyway. Ctrl+w doesn't seem to be blocked at all and Shift+Ctrl+W falls back to some devtools command instead of closing the window or doing nothing.
Blocks: 392820
Component: Theme → Bookmarks & History
Comment hidden (mozreview-request)
(Assignee)

Updated

5 months ago
Blocks: 1459877

Comment 3

5 months ago
I agree, ctrl/cmd+w is not a common shortcut to close a panel, now ESC works (didn't when this was implemented), plus the panel can auto hide now.

Comment 4

5 months ago
mozreview-review
Comment on attachment 8988699 [details]
Bug 1468077 - Stop disabling cmd_close and cmd_closeWindow in the bookmark panel since it seems to be half-broken and is inconsistent with other panels.

https://reviewboard.mozilla.org/r/253914/#review260796
Attachment #8988699 - Flags: review?(mak77) → review+

Comment 5

5 months ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f1115c6eeefc
Stop disabling cmd_close and cmd_closeWindow in the bookmark panel since it seems to be half-broken and is inconsistent with other panels. r=mak

Comment 6

5 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f1115c6eeefc
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 63
(Reporter)

Comment 7

5 months ago
Looking good on latest Nightly.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

5 months ago
Comment on attachment 8988699 [details]
Bug 1468077 - Stop disabling cmd_close and cmd_closeWindow in the bookmark panel since it seems to be half-broken and is inconsistent with other panels.

Approval Request Comment
[Feature/Bug causing the regression]: bug 392820 and 1441102
[User impact if declined]: see comment 0
[Is this code covered by automated tests?]: no
[Has the fix been verified in Nightly?]: no
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: straightforward removal of an obsolete and broken feature (see comment 1)
[String changes made/needed]:
Attachment #8988699 - Flags: approval-mozilla-beta?
Comment on attachment 8988699 [details]
Bug 1468077 - Stop disabling cmd_close and cmd_closeWindow in the bookmark panel since it seems to be half-broken and is inconsistent with other panels.

Fix for behavior in bookmarks pop-up, let's take this for 62 beta 6.
Attachment #8988699 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Updated

5 months ago
Keywords: checkin-needed
(Assignee)

Updated

5 months ago
Keywords: checkin-needed

Comment 10

5 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/b55af4da7030
status-firefox62: fix-optional → fixed
Flags: qe-verify+
Hello guys, 

I have reproduced the issue mentioned in Description using the affected 62.0a1(2018-06-10) build.

This issue is verified fixed using the latest FF Nightly 63.0a1(2018-07-05)and the latest FF Beta 62.0b6 on Windows 10x32bit on both AR and ER builds.
status-firefox62: fixed → verified
status-firefox63: fixed → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.