Closed Bug 1469611 Opened 2 years ago Closed 1 year ago

translation time filter isn't automatically applied on changes

Categories

(Webtools :: Pontoon, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: felix.bau, Assigned: mathjazz)

References

Details

Attachments

(1 file)

131.90 KB, image/png
Details
Attached image Crowdin
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0
Build ID: 20180614220111

Steps to reproduce:

You can follow what I did by watching this video:
https://youtu.be/kRhhfVFGamo

Open https://pontoon.mozilla.org/de/common-voice/messages.ftl/
Select a date, check the filter and click apply to activate it.
Take a look at the string list -> it works

Edit the date
Apply the filter
Nothing changes

uncheck and check the checkbox
apply again
The string output changed

I edited the date a second time in the video, because apparently there weren't many changes between the first and the second date.
The third date makes it obvious -> way less strings after I recheck the checkbox


Actual results:

Pontoon only seems to apply the translation time filter, when I uncheck and check the checkbox before it, which is not apparent at all.

It took me some time to figure out, why the time filters, I tried, didn't change the output.

It's also very confusing, that 30 days, 7 days, 24h and 60mins are subtracted off the time of the last changed string, when the strings themselves tell you the amount of days/hours from the current time instead.
I wondered why an 11 days old string change was included, when I select last 7 days.
You should either make them use the last x days/hours since the current date or show absolute dates below each string instead of relative dates to avoid this confusion.


Expected results:

You could also implement a different feature that would be superior to the date filter:
An activity view like on Crowdin (take a look at the attached screenshot).

It groups string changes by Date (the day) and user.
And you can also filter by user, event type (suggestion, approval, deletion etc.) and language.
This view allows you to find strings that were changed since your last visit of the file (for translation) much easier.
And it shows a lot more information at once.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

This bug has been as part of bug 1510190.

I'm also adding a note about the Activity feature to bug 1473760.

Assignee: nobody → m
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
See Also: → 1473760
You need to log in before you can comment on or make changes to this bug.